Find the answer to your Linux question:
Results 1 to 9 of 9
I work at a school and am in charge of maintaining the school's firewall. A teacher gave me a site ( www.weathertalk.com ) to add to the block list, which ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2003
    Posts
    41

    Don't laugh ... porn problems!


    I work at a school and am in charge of maintaining the school's firewall. A teacher gave me a site (www.weathertalk.com) to add to the block list, which use to be a valid weather site, and at some point became a porn site.

    It is common practice to verify the contents of a site before blocking it. This I did, on my Linux box. Now, any time I start X/KDE, I get a couple of X-rated popups. I'm sure these are somewhere in a startup scripts for X or KDE, but I've been unable to locate them, as I am still a Linux newb.

    Can anyone give me a hint as to where to look for this?

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    I believe the X startup scripts are /etc/rc.d (???), but I doubt a website could modify those. KDE startup scripts are found in /home/user/.kde/Autostart. I'd start there.

    I'm curious what happens when you start Gnome?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Linux Newbie
    Join Date
    Apr 2004
    Location
    Stockholm, Sweden
    Posts
    130
    First of all, how did you do when you "verifyed" that this was indeed a pr0n site...?

    And secondly, if this things keep popping up every time you start KDE, then it probably has something to do with the session settings....

    I can't say what exactly would be the problem,
    but I would try to check session settings and such
    for KDE ...

    /ooop

  4. #4
    Just Joined!
    Join Date
    Dec 2003
    Posts
    41
    1. I checked the .kde/Autostart directory, and found only a .directory file.
    2. It would seem to me that if anything got changed in the rc.d directory, that it would affect the computer systemwide, not only KDE.
    3, When I run Gnome, I don't get the popups. Therefore it does appear to be directly related to KDE. I get the feeling that Konquerer is somehow the cuplrit, as that is my primary web browser, and the one I use to check the sites.
    4. I'm not sure where to look for the session settings. I don't believe they're stored in the .kde directory.
    5. To ooop: I'm not sure the nature of your question as to how I check for verification, but I don't know how to check difinitively the nature of a site except to visit it directly.
    6. At the risk of being slapped around by the Linux gurus here, I guess it would be a good idea to tell you that I am using the root account. I know it's stupid, and I should kick myself.

  5. #5
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    6. At the risk of being slapped around by the Linux gurus here, I guess it would be a good idea to tell you that I am using the root account. I know it's stupid, and I should kick myself.
    Damn foolish idea.

    Regardless, clear the cache, cookies and tmp files for Konqueror. If you don't know where they're at, you can find the info here:

    http://docs.kde.org/en/3.2/kdebase/k...html#id2897626

    Good luck. Oh and BTW... try running as user

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  6. #6
    Linux Engineer big_k105's Avatar
    Join Date
    May 2003
    Location
    Fargo, ND
    Posts
    901
    well im not sure what could be the problem but as you are running as root. it could be a number of places. because that means that it could write the to any file on your system. i would recommend maybe running a file on the domain name that is popping up and see if you find anything that could be the cause of the problem good luck. and try to use a user account from now on
    BIG K aka Kyle
    Programming Forums
    www.kylekonline.com
    Please don\'t PM me for help-- ask in the forums instead!

  7. #7
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    well im not sure what could be the problem but as you are running as root. it could be a number of places. because that means that it could write the to any file on your system.


    I didn't even think of that! Just one (million) more reason(s) to not run as root. Especially when surfing the net.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  8. #8
    Just Joined!
    Join Date
    Dec 2003
    Posts
    41
    Ok, I've been appropriately beaten by the guys here for my stupidity. I'll make sure to change my ways.

    Here's what I found:
    I grepped and found the url in a file located in ~/.kde/share/config/session/konquorer... I checked another linux system and found that the other system did not have this file, so I trashed the file. Now all that pops up is an empty Konquerer window instead of the offending page. So now I feel I'm moving closer to the fix. For the sake of interest, I'd like to be able to get rid of the blank window also.

    Trust me folks, I'm learning a lot here, so I really appreciate the help here.

    Any ideas on the blank window?

  9. #9
    Just Joined!
    Join Date
    Dec 2003
    Posts
    41
    I figured it out! I removed entries in ~/.kde/share/config/ksmserverrc that started konqueror.

    I've got to admit that learning Linux, while fun for me, can also be nerve-racking.

    Anyway ... I'll be sure to use a non-root account, and thanks for all the help you've provided.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •