Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, I'm kinda new to GDM. When I tried to compile it, it gives me an error: sh-3.00# ./configure --with-x checking for a BSD-compatible install... /usr/bin/install -c checking whether build ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4

    GDM Compiling Error


    Hello,

    I'm kinda new to GDM.

    When I tried to compile it, it gives me an error:

    sh-3.00# ./configure --with-x
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for intltool >= 0.35.0... 0.35.0 found
    checking for perl... /usr/bin/perl
    checking for XML::Parser... ok
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for intltool >= 0.35.0... 0.35.0 found
    checking for perl... /usr/bin/perl
    checking for XML::Parser... ok
    sh-3.00# ./configure --with-x
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for intltool >= 0.35.0... 0.35.0 found
    checking for perl... /usr/bin/perl
    checking for XML::Parser... ok
    checking for iconv... /usr/bin/iconv
    checking for msgfmt... /usr/bin/msgfmt
    checking for msgmerge... /usr/bin/msgmerge
    checking for xgettext... /usr/bin/xgettext
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for GDU_MODULE_VERSION_CHECK... configure: error: Package requirements (gnome-doc-utils >= 0.3.2) were not met:

    Package gnome-doc-utils was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gnome-doc-utils.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'gnome-doc-utils' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables GDU_MODULE_VERSION_CHECK_CFLAGS
    and GDU_MODULE_VERSION_CHECK_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    sh-3.00#
    So then I downloaded gnome-doc-utils 0.10.1, and "installed" it. (There's a reason why I put that in quotes, you'll see later.)

    And then I ran the configure script for GDM 2.16 again.
    And STILL this keeps telling me the same message above.

    I have no idea what to do now. Can you please help?

  2. #2
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    May I ask why you are trying to install GDM from source? You could easily get this through a package manager as GDM is a common DM.

    What distro are you using?
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  3. #3
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4
    I'm using puppyOS, which is a recompiled mix of Slackware/Devbian. NO installers are included(no apt-get, whatever it is....)

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •