Find the answer to your Linux question:
Results 1 to 10 of 10
I got Beryl up and running a few days back on a very fresh Ubuntu 7.04 installation. It looks and runs great on my system, but it doesn't initialize automatically ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Location
    Mesa, AZ, aka 20cm from the Sun!
    Posts
    49

    Beryl question


    I got Beryl up and running a few days back on a very fresh Ubuntu 7.04 installation. It looks and runs great on my system, but it doesn't initialize automatically when I log in; I have to click on Applications/System Tools/Beryl, then it begins to run. I'd really like it to load Beryl automatically, and I've dug around in the settings trying to make this happen but haven't seen it. Could you point me in the right direction, or let me know what I might have done wrong?
    Thanks

  2. #2
    Just Joined!
    Join Date
    Mar 2007
    Posts
    47

    How to start Beryl automatically

    Hi!

    I have GNOME Ubuntu and I can tell you how I do it here. In your system it should be more or less similar. In GNOME (that's when you login to your graphic interface):



    Go to System > Preferences > Sessions
    Go to the 'Startup Programs' tab
    Click the 'Add' button and type beryl-manager into the dialog box
    Click 'Close'


    This procedure should be done in each user of your system one by one. There is no way that I know of to set it up for all users at once.

    Please tell me how did it go...

    Hope this helps,

    Joe

  3. #3
    Just Joined!
    Join Date
    Apr 2007
    Location
    Mesa, AZ, aka 20cm from the Sun!
    Posts
    49
    Joe, thanks. It took a couple of tries, and for some reason I also had to also define a custom theme in the windows preferences in my user account that used Beryl themes, but it seems to be working. The only other account on the system is the root account; I just left it alone, as I only get into when necessary.
    Thanks again for the help.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2007
    Location
    Mesa, AZ, aka 20cm from the Sun!
    Posts
    49

    I spoke too soon...

    No, it's defaulting back to Metacity again. I logged off, logged in as root to get firestarter installed. Pop back in to my user account and doesn't apply. THe Beryl icon does show up in the tray now, but it keeps wanting to load metacity. I can't seem to get to take Beryl as the default.

  6. #5
    Just Joined!
    Join Date
    Mar 2007
    Posts
    47

    Second non administrative user

    Hi!

    It is a good idea to have a second user account that doesn't have administartive privileges. That way you can protect yourself from yourself in the sense that if administrative privileges aren't allowed, you can't make substantial changes on your system when you are working on something else. Huge system changes can only be done when you intentionally enter the administrator account. Also, this way you can leave your machine doing very long tasks (download a big torrent) without the risk of somebody making changes on your system intendedly.

    Also, if your system runs ok, I recommend making an image backup of your Linux hard drive, so you donīt have to reinstall everything in the future (in Win XP use Acronis. In Linux use partimage.

    Hope this helps,

    Joe.

  7. #6
    Just Joined!
    Join Date
    Apr 2007
    Location
    Mesa, AZ, aka 20cm from the Sun!
    Posts
    49
    So do I need to set Beryl up in my root account to get it to apply automatically to the user account as well? I did catch the lesson early on about keeping a separate user account and user account, and use the root only for maintenance and installing programs like firestarter that make root-privilege changes. I haven't bothered with Beryl in the root account, as I don't really need the eye candy to do maintenance.

  8. #7
    Just Joined!
    Join Date
    Mar 2007
    Posts
    47

    Gnome Or Kde?

    Hi!

    No. That's not what I meant. You should setup the Beryl session startup for each user. It's the same for administrators and common users.

    Now I need to know if you have GNOME, KDE or XCFE (or other) graphic interface. Can you tell me?

    See you,

    Joe

  9. #8
    Just Joined!
    Join Date
    Apr 2007
    Location
    Mesa, AZ, aka 20cm from the Sun!
    Posts
    49
    GNOME is what comes as the standard DE for Ubuntu, so that's what I've been using. I'm also installing KDE using Synaptic right now, actually, though I'll probably continue to use GNOME as the default. I haven't really had enough experience yet to figure out which I like better; I had PCLinuxOS on there for a couple of weeks and that used KDE as the default, but removed it and installed Ubuntu after serious issues getting it to play nice w/ my ATi graphics card, which Ubuntu worked with N/P.

  10. #9
    Just Joined!
    Join Date
    Mar 2007
    Posts
    47
    Hi!

    First open a Terminal window (Applications/Accesoryes/Terminal)

    Then type in:

    beryl-manager

    and see what happens.

    If Beryl loads correctly, you have made some sort of mistake setting up the session startup (the instructions in my first post).

    If it doesn't load, in terminal mode you can catch some errors that might happen while lauchin Beryl.

    Is the ATI driver correct?

    In this regard I recommend to download the Envy driver installer from:

    http://www.albertomilone.com

    It also installs drivers for ATI.

    If later you have a bad experience with ATI's Open GL or have stability problems (Beryl sometimes gets stuck), which was my case, I recommend buying an nVidia GeForce video card with 128 MB RAM. The Envy driver installer also installs drivers for nVidia cards.

    Hope this helps,

    Joe

  11. #10
    Just Joined!
    Join Date
    Apr 2007
    Location
    Mesa, AZ, aka 20cm from the Sun!
    Posts
    49
    Joe,
    For some reason I can't seem to figure out, ever since I also installed KDE, it's popped right up w/ Beryl after logging off/on and system restarts. I'm not sure why that is, but I'm not complaining too loudly about it. Thanks for working with me to get this up and running; if other issues pop up with it, I'll repost, but for now, I'll just enjoy it. Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •