Find the answer to your Linux question:
Results 1 to 2 of 2
I am running FC2 with the default 2.6.5-1.358 kernel. Just recently (today, 06/04/04), after performing an update via yum, restarting the computer, and logging in, I get the following error ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    2

    cannot find or run the base session script


    I am running FC2 with the default 2.6.5-1.358 kernel. Just recently (today, 06/04/04), after performing an update via yum, restarting the computer, and logging in, I get the following error message:

    "Cannot find or run the base session script, will try the GNOME failsafe session for you."

    After this everything seems normal. I tried to log into KDE, instead of Gnome, but I get the same error message and the desktop looks like Gnome. Here is a post of my yum.log file. I think it may have to do with one of the packages I upgraded/installed on 06/04/04...i.e. the last three, but I'm not sure. Can I downgrade to the previous versions? I would appreciate any help in this matter, as I appear to be unable to run startup scripts. Thanks.

    05/21/04 17:01:01 Updated: kdelibs 6:3.2.2-6.i386
    05/21/04 17:01:01 Updated: libgnome 2.6.0-3.i386
    05/21/04 17:01:01 Updated: cvs 1.11.15-6.i386
    05/21/04 17:01:01 Updated: nfs-utils 1.0.6-22.i386
    05/22/04 14:42:46 Installed: xine 0.99.1-1.1.fc2.fr.i386
    05/22/04 14:42:46 Dep Installed: xvidcore 1.0.0-1.1.fc2.fr.i386
    05/22/04 14:42:46 Dep Installed: libfame 0.9.1-1.1.fc2.fr.i386
    05/22/04 14:42:46 Dep Installed: freeglut 2.2.0-11.i386
    05/22/04 14:42:46 Dep Installed: xine-lib 1.0.0-0.13.rc4a.1.fc2.fr.i386
    05/22/04 14:42:46 Dep Installed: aalib 1.4.0-5.1.fc2.fr.i386
    05/22/04 14:42:46 Dep Installed: libdvdcss 1.2.8-4.1.fc2.fr.i386
    05/24/04 18:09:43 Dep Installed: id3lib 3.8.3-6.1.fc2.fr.i386
    05/24/04 18:09:43 Updated: yum 2.0.7-2.fc.fr.noarch
    05/24/04 18:09:43 Updated: gthumb 2.3.3-1.1.fc2.fr.i386
    05/24/04 18:09:43 Updated: xmms-mp3 1:1.2.10-2.2.p.1.fc2.fr.i386
    05/24/04 18:09:43 Updated: xmms 1:1.2.10-2.2.p.1.fc2.fr.i386
    05/24/04 18:09:43 Updated: rhythmbox 0.8.4-1.1.fc2.fr.i386
    05/24/04 18:09:43 Updated: grip 1:3.2.0-2.1.fc2.fr.i386
    05/24/04 18:09:43 Updated: xmms-skins 1:1.2.10-2.2.p.1.fc2.fr.i386
    05/28/04 13:41:44 Updated: flash-plugin 7.0.25-1.i386
    06/03/04 14:17:16 Installed: mozplugger 1.5.2-1.i386
    06/03/04 14:18:09 Updated: xinitrc 3.41-1.noarch
    06/03/04 15:03:18 Installed: mplayer 1.0-0.10.pre4.1.fc2.fr.i386
    06/03/04 15:03:18 Dep Installed: faad2 2.0-1.1.fc2.fr.i386
    06/03/04 15:03:18 Dep Installed: libmad 0.15.1b-2.1.fc2.fr.i386
    06/03/04 15:03:18 Dep Installed: mplayer-fonts 1.1-2.fr.noarch
    06/03/04 15:03:18 Dep Installed: lirc 0.6.6-2.1.fc2.fr.i386
    06/03/04 15:03:18 Dep Installed: libpostproc 1.0-0.10.pre4.1.fc2.fr.i386
    06/03/04 15:03:18 Dep Installed: libdvdread 0.9.4-5.1.fc2.fr.i386
    06/03/04 15:03:18 Dep Installed: lame 3.96-1.1.fc2.fr.i386
    06/03/04 15:03:18 Dep Installed: lzo 1.08-3.1.fc2.fr.i386
    06/04/04 12:48:23 Updated: krb5-devel 1.3.3-7.i386
    06/04/04 12:48:23 Updated: strace 4.5.4-1.i386
    06/04/04 12:48:23 Updated: krb5-libs 1.3.3-7.i386

    Here is my yum.conf:

    [main]
    cachedir=/var/cache/yum
    debuglevel=2
    logfile=/var/log/yum.log
    pkgpolicy=newest
    distroverpkg=fedora-release
    tolerant=1
    exactarch=0
    # Added this because some mirrors go down and then retying takes forever.
    retries=1

    ##################
    ## Basic Fedora ##
    ##################

    [base]
    name=Fedora Core $releasever - $basearch - Base
    baseurl=http://mirror.hiwaay.net/redhat/fedora/linux/core/$releasever/$basearch/os
    http://rpmfind.net/linux/fedora/core/$releasever/$basearch/os
    http://mirror.clarkson.edu/pub/dist...ora/linux/core/$releasever/$basearch/os
    http://mirrors.usc.edu/pub/linux/fedora/fedora/fedora/$releasever/$basearch/RPMS.os
    http://download.fedora.redhat.com/p...ora/linux/core/$releasever/$basearch/os
    #http://fedora.redhat.com/releases/fedora-core-$releasever
    #gpgcheck=1

    [updates-released]
    name=Fedora Core $releasever - $basearch - Released Updates
    baseurl=http://ftp.ens.utulsa.edu/pub/linux/fedora/core/updates/$releasever/$basearch
    http://rpmfind.net/linux/fedora/core/updates/$releasever/$basearch
    http://mirror.clarkson.edu/pub/dist...x/core/updates/$releasever/$basearch
    http://mirrors.usc.edu/pub/linux/fedora/fedora/fedora/$releasever/$basearch/RPMS.updates
    # http://fedora.redhat.com/updates/released/fedora-core-$releasever
    #gpgcheck=1

    ###################
    ## Fedora Extras ##
    ###################

    [fedora-stable]
    name=Fedora.us Extras (Stable)
    baseurl=http://mirrors.kernel.org/fedora.us/fedora/fedora/$releasever/$basearch/RPMS.stable
    http://fedora.quicknet.nl/fedora/fedora/$releasever/$basearch/RPMS.stable
    http://mirrors.usc.edu/pub/linux/fedora/fedora/fedora/$releasever/$basearch/RPMS.stable
    http://fedora.mirror.sdv.fr/fedora/fedora/$releasever/$basearch/RPMS.stable
    http://download.fedora.us/fedora/fedora/$releasever/$basearch/RPMS.stable
    #gpgcheck=1

    ###############
    ## Livna.org ##
    ###############

    [livna-stable]
    name=Livna.org - Fedora Compatible Packages (stable)
    baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/yum/stable
    #gpgcheck=1

    #[livna-unstable]
    #name=Livna.org - Fedora Compatible Packages (unstable)
    #baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/yum/unstable
    #gpgcheck=1

    ############################
    ## Alternate Repositories ##
    ############################

    # Uncomment these to use them -- note that some packages
    # from these repositories may conflict with the fedora.us
    # packages. If you use these repositories, you may wish to
    # comment-out the fedora.us and livna.org repositories.

    #[freshrpms]
    name=FreshRPMs
    baseurl=http://ayo.freshrpms.net/fedora/linux/$releasever/$basearch/freshrpms/
    http://ftp.us2.freshrpms.net/linux/...o/fedora/linux/$releasever/$basearch/freshrpms/
    ##gpgcheck=1

    #[dag]
    #name=Dag APT Repository
    #baseurl=http://dag.freshrpms.net/redhat/fc$releasever/en/$basearch/dag
    # http://ftp.heanet.ie/pub/freshrpms/pub/dag/redhat/fc$releasever/en/$basearch/dag
    ##gpgcheck=1

    ###################
    ## Miscellaneous ##
    ###################

    [macromedia.mplug.org]
    name=macromedia.mplug.org - Flash Plugin
    baseurl=http://macromedia.mplug.org/apt/fedora/$releasever
    http://sluglug.ucsc.edu/macromedia/apt/fedora/$releasever
    http://ruslug.rutgers.edu/macromedia/apt/fedora/$releasever
    http://macromedia.rediris.es/apt/fedora/$releasever
    #gpgcheck=1

  2. #2
    Just Joined!
    Join Date
    Jun 2004
    Posts
    2

    Problem identified

    So after doing some research via Google, the not-so-obvious culprit was updating to xinitrc-3.41-1 from 3.39-1 using yum. So I simply downloaded xinitrc-3.39-1 and did:

    rpm -Uvh --force xinitrc-3.39-1

    to reinstall the older version. Sure enough, no error message after logging in...strange. Any thoughts? I don't know if updating this again using up2date will recreate the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •