Find the answer to your Linux question:
Results 1 to 8 of 8
Hi everyone, I have a Acer laptop, and I installed Debian 4.0 etch just a few days ago. When I installed the X system and was asked for the resolution, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Posts
    4

    Change resolution


    Hi everyone,

    I have a Acer laptop, and I installed Debian 4.0 etch just a few days ago. When I installed the X system and was asked for the resolution, I checked 1024x768. Soon I found I should have choosen a higher one, because when I'm using KDE, everything is big and the webpages do not show up nicely in my browser.

    I'm sure my graphic card can support a higher resolution, because my Windows XP (also on this machine) is using 1280x800. But in the drop down menu at "Configure Desktop" I am limited to 1024x768.

    So I found some articles about how to change resolution. I turned off kdm, reconfigure the X system:
    Code:
    dpkg-reconfigure xserver-xorg
    and check 1280x800 this time.

    Now I turn kdm back on. However, the highest available resolution on the drop down menu of KDE is still 1024x768. I don't know why. I checked my xorg.conf and the resolution 1280x800 is there. Can anybody help me?

    This is my xorg.conf:

    Code:
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    	FontPath	"/usr/share/fonts/X11/misc"
    	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
    	FontPath	"/usr/share/fonts/X11/cyrillic"
    	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
    	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
    	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
    	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/Type1"
    	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
    	FontPath	"/usr/share/fonts/X11/100dpi"
    	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
    	FontPath	"/usr/share/fonts/X11/75dpi"
    	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
    	# path to defoma fonts
    	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
    	Load	"bitmap"
    	Load	"ddc"
    	Load	"dri"
    	Load	"extmod"
    	Load	"freetype"
    	Load	"glx"
    	Load	"int10"
    	Load	"vbe"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc104"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"		"/dev/psaux"
    	Option		"Protocol"		"auto-dev"
    	Option		"HorizScrollDelta"	"0"
    EndSection
    
    Section "Device"
    	Identifier	"Generic Video Card"
    	Driver		"vesa"
    	BusID		"PCI:0:2:0"
    EndSection
    
    Section "Monitor"
    	Identifier	"Generic Monitor"
    	Option		"DPMS"
    	HorizSync	28-64
    	VertRefresh	43-60
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"Generic Video Card"
    	Monitor		"Generic Monitor"
    	DefaultDepth	24
    	SubSection "Display"
    		Depth		1
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    	InputDevice	"Synaptics Touchpad"
    EndSection
    
    Section "DRI"
    	Mode	0666
    EndSection

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    HorizSync 28-64
    VertRefresh 43-60

    EndSection
    HorizSync and VertRefresh rates are low. check manuals and set correct/supported values.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jun 2007
    Posts
    4
    I change the horizontal sync rate to 31.5-79.0 and the vertical one to 50-100. Still I only have 1024x768, 800x600, 640x480 on the dropdown menu. Only the refresh rate increase. I use xrandr, and it's the same.

    What manual should I look up for the correct horizonal/vertical sync rate for my monitor?

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    What manual should I look up for the correct horizonal/vertical sync rate for my monitor?
    check your Monitor's Manual.
    did you reboot machine after setting correct rates in xorg?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Jun 2007
    Posts
    4
    I still can not find it in the manual....
    And yes I did reboot my machine after the setting

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    search for Manual of your Monitor's Model on net. check Manufacturer's Website.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Linux User netstrider's Avatar
    Join Date
    Jul 2005
    Location
    South Africa
    Posts
    476
    Have you tried 1280x1024 yet? Since the first resolution you had (1024x76 is fairly squarish in comparison to wide-angle 1280x800. Give it a shot (it might look crappy though)

  8. #8
    Just Joined!
    Join Date
    Jun 2007
    Posts
    4
    I installed the package 915resolution and I can use the 1280x800 resolution now. I'm not sure why it works but it's working. Thanks everybody.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •