Find the answer to your Linux question:
Results 1 to 5 of 5
After I made an XGL script to log into an XGL session I managed to get Beryl to work. When I press the power button it should show me some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! borimrr's Avatar
    Join Date
    Apr 2007
    Location
    Seffner, FL
    Posts
    28

    Cant log out!!!


    After I made an XGL script to log into an XGL session I managed to get Beryl to work. When I press the power button it should show me some options but instead it sppears to crahs and I land in a black screen. I have to restart to be able to log back in. This also happens when I try to log out. This happens on both the XGL and regular session. Im running Ubuntu Feisty on a compaq v2000.

  2. #2
    Linux Newbie Tutku's Avatar
    Join Date
    Jul 2007
    Location
    Izmir / Turkey
    Posts
    167
    i think you don't have enough permissions to halt the computer as a normal user. For solve it, open /etc/sudoers file as root and add this line:

    Code:
    username  machinename = NOPASSWD: /sbin/shutdown -h now
    usename  machinename= NOPASSWD: /sbin/reboot
    after saving file, change its permissions with:
    Code:
     chmod 0440 /etc/sudoers
    command.

    After all you'll be able to shutdown by using
    Code:
    sudo shutdown -h now
    command.

  3. #3
    Just Joined! borimrr's Avatar
    Join Date
    Apr 2007
    Location
    Seffner, FL
    Posts
    28

    Done

    I know I can shut it down through the terminal but I didn't want to. Anyway I fixed the problem but I forgot how I did it. Thx for the response.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    I know I can shut it down through the terminal but I didn't want to. Anyway I fixed the problem but I forgot how I did it. Thx for the response.
    You must be using different Login Manager. e.g. If one uses GDM then there wont be any option in KDE except Logout and Switch User. Same is with KDM and Gnome combination.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined! borimrr's Avatar
    Join Date
    Apr 2007
    Location
    Seffner, FL
    Posts
    28
    I use Gnome and GDM, but like I said it's ok now I went to the ubuntu forums and found how to fix it but I forgot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •