Find the answer to your Linux question:
Results 1 to 5 of 5
I have been using Linux for some time now and I know how to configure X and have never had a problem with it until now. I installed Debian last ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2002
    Posts
    6

    Startx fails on new Debian Install


    I have been using Linux for some time now and I know how to configure X and have never had a problem with it until now. I installed Debian last night and ran through the provided X configuration that it takes you through. Upon rebooting I ran startx and it failed with "no screens found". I then decided to just run the xf86config and configure X like I do in Gentoo and Slackware (which always works). I ran through the config putting in my information for my video card (Viper V770, 32meg) and Monitor (Dell 17", H=30-70;V=50-160). I then saved the file and ran startx fully expecting it to work, but alas, it errored out with "no screens found". What is soooo different about Debian from Slackware or Gentoo???? Has anyone else seen this and if so how did you fix it. I know I have the correct information configured for my monitor and video card.

  2. #2
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Open XF86Config and check your screen section. Make sure you have valid resolutions and color depth there.

  3. #3
    Just Joined!
    Join Date
    Apr 2002
    Posts
    6
    I am pretty sure I do because I configure it the same for slackware and Gentoo, but I will definitely check it. Thanks.

  4. #4
    Just Joined!
    Join Date
    Mar 2003
    Location
    Portland, OR
    Posts
    2
    heh...go back through Debconf "dpkg-reconfigure xfree86" and disable framebuffer. If it is already disabled..enable it.


    I forget it might be "dpkg-reconfigure xfree86-xserver"...I usually end up calling debconf at around 3 am..so its hard to remember the commands during the day.

  5. #5
    Just Joined!
    Join Date
    Apr 2002
    Posts
    6
    Thanks I will give that a try. I am going to start my install over tonight when I get home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •