Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I am usually not a slow learner. However xmodmap remains a mystery to me! I have studied examples, read the manual, searched the web, ... I still do not ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Posts
    6

    Arrow Modifying the keyboard (with a teaspoon!)


    Hi,

    I am usually not a slow learner. However xmodmap remains a mystery to me! I have studied examples, read the manual, searched the web, ... I still do not get it.

    Please explain in detail in ultra–slow–motion–using–a–teaspoon how to modify my hyphen key. I want it to work like this:
    • - = hyphen-minus (-) U+002D
    • Menu + - = figure dash (‒) U+2012
    • AltGr + - = en dash (–) U+2013
    • AltGr + Shift + -= em dash (—) U+2014

    Thanks for your patience!

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Location
    London
    Posts
    1
    If you are still there and waiting, Alek, try this:

    1. Start a text editor and enter this line
    xmodmap -e 'keycode 20 = minus figdash endash emdash'
    2. Save in your home directory with a suitable name like ~/.mykeys
    3. Enter the menu and find in the system-preferences-sessions box the startup programs option. Add an entry for the script you've just written, like /home/alex/.mykeys

    This should work. Mind you, on my system only the first two definitions get read: the AltGr ones are ignored!

    The alternative is to go to /usr/share/X11/xkb/symbols/latin or /etc/X11/xkb/symbols/latin (different distros use different addresses) and alter the file.

    Incidentally, are you sure you won't need the underscore character? And the en-dash and figure-dash will probably be the same: they are in any printer's fonts I've ever met. The extra point in Unicode is probably for languages like Russian where there's no en-dash and they use the em-dash instead.

  3. #3
    Just Joined!
    Join Date
    Jul 2007
    Posts
    6
    Quote Originally Posted by DavidMcCann View Post
    If you are still there and waiting, Alek, try this:

    1. Start a text editor and enter this line
    xmodmap -e 'keycode 20 = minus figdash endash emdash'
    2. Save in your home directory with a suitable name like ~/.mykeys
    3. Enter the menu and find in the system-preferences-sessions box the startup programs option. Add an entry for the script you've just written, like /home/alex/.mykeys

    This should work. Mind you, on my system only the first two definitions get read: the AltGr ones are ignored!
    Are the keycodes the same om every computer? What does the arangement of the dashes have to say? Which keys, etc?

    Quote Originally Posted by DavidMcCann View Post
    The alternative is to go to /usr/share/X11/xkb/symbols/latin or /etc/X11/xkb/symbols/latin (different distros use different addresses) and alter the file.

    Incidentally, are you sure you won't need the underscore character? And the en-dash and figure-dash will probably be the same: they are in any printer's fonts I've ever met. The extra point in Unicode is probably for languages like Russian where there's no en-dash and they use the em-dash instead.
    I meant horizonal bar and not figure dash.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •