Find the answer to your Linux question:
Results 1 to 10 of 10
This problem is specific to FreeBSD as I understand it. I have done the following to activate the numlock key at startup: cd /usr/ports/x11/numlockx/ make install clean However the boot/loader.conf ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Dec 2004
    Posts
    323

    KDE/FreeBSD numlock key problem


    This problem is specific to FreeBSD as I understand it. I have done the following to activate the numlock key at startup:
    cd /usr/ports/x11/numlockx/
    make install clean

    However the boot/loader.conf file makes no mention of a numlock key.

    When the computer starts up, the numlock key is activated, but as soon as X starts, numlock is being deactivated. How can this be solved: I want the numlock key on when KDE has loaded.

    Thanks in advance

  2. #2
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    You'll need to invoke numlockx when X starts. For example, I use fluxbox - here's my ~/.xinitrc:
    Code:
    numlockx on &
    exec fluxbox

  3. #3
    Linux User
    Join Date
    Dec 2004
    Posts
    323
    Thanks for the response. Unfortunately that did not work and I still have to manually activate the numlock key. Currently I have this in ~/.xinitrc:
    Code:
    xsetroot -solid "#4a6a8a"
    
    # Force 96 DPI
    xrdb -quiet -merge -nocpp <<EOF
    Xft.dpi: 96
    EOF
    
    numlockx on &
    kwin &
    dbsd-initialconf && /usr/local/share/desktopbsd/initialconf/finish-cfg.sh
    If there is anything you see that is incorrect, please let me know.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    For KDE try adding it to ~/.xession. (That's appropriate for xdm; I'm not sure about kdm.)

    If no luck, then see this gentoo tip under the "for KDM users" section. The FBSD path may differ slightly.

    If still no good, does the numlockx command work when run within a terminal (with X running)?

  6. #5
    Linux User
    Join Date
    Dec 2004
    Posts
    323
    Thank you for your response. First of all, there is no file .xsession. I do have .xsession-errors however, which appears to contain some logging data.
    If I type numlockx in bash, the following is shown:
    Code:
    # numlockx
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified
    
    Error opening display!
    What approach to take now?

  7. #6
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    Maybe I wasn't clear enough -- start X, and then run numlockx (not as root) from a terminal. Does that enable your NumLock?

  8. #7
    Linux User
    Join Date
    Dec 2004
    Posts
    323
    Yes, that works. Now I suppose I need to enable this in a start up script somewhere? And will this work for the user that is logged in only or for all users who happen to login?

  9. #8
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I'm not sure if this applies to BSD or not, but in KDE 3.5 you can go to Control Center>Peripherals>Keyboard>NumLock on KDE start up
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  10. #9
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    Again, I run fluxbox (not KDE), so I can't speak to this definitively, but I would try the suggestions at the gentoo tips page I cited and MikeTbob's suggestion above.

  11. #10
    Linux User
    Join Date
    Dec 2004
    Posts
    323
    Thanks, that worked. I will find out someday what script was written to to enable this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •