Find the answer to your Linux question:
Results 1 to 6 of 6
Im trying to mount my USB pendrive but i can do it only as root and with the long way. I can mount it using Code: #mount -t msdos /dev/da0s1 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Location
    Mexico
    Posts
    65

    Why can't i mount a USB pendrive with the short way nor normal user???


    Im trying to mount my USB pendrive but i can do it only as root and with the long way.

    I can mount it using
    Code:
    #mount -t msdos /dev/da0s1 /mnt/dti
    and it does it

    also i try
    Code:
    #mount /mnt/dti
    but shown an error, i don't remember which

    and as normal user ( console and xffm on xfce4 ) shows:
    Code:
    $mount -t msdos /dev/da0s1 /mnt/dti
    mount_msdos_ -o user: option not supported
    
    $mount /mnt/dti
    mount_msdos_ -o user: option not supported
    I already added a line in fstab:
    /dev/da0s1 /mnt/dti msdos rw,user,noauto 0 0

    the folder /mnt/dti is owned by my normal user with all persissions.

    Which could be my mistake???

    Thanks to all

  2. #2
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    To mount usb drives as a normal user start at this section:
    To make this device mountable as a normal user, certain steps have to be taken...

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Location
    Mexico
    Posts
    65
    Oh my . . .

    that is dark magick

    I thaught that it isn't different than linux

    Thanks

    I need to be more familiar with this ways.

  4. #4
    Just Joined!
    Join Date
    Oct 2007
    Location
    Mexico
    Posts
    65
    i followed the guide but don't works

    -added an user with:
    pw groupmod operator -M myuser

    -added rule to /etc/devfs.conf (devfs.rules don't exists) :
    [localrules=1]
    add path 'da*' mode 0660 group operator
    (also i try 'da0s1')

    -enabled ruleset on /etc/rc.conf
    devfs_system_ruleset="localrules"

    -mount fs allowed to normal users on /etc/sysctl.conf
    vfs.usermount=1

    and created a directory named "myuser" on /mnt, owned by my user with all privileges

    also i have a line on fstab:
    /dev/da0s1 /mnt/myuser msdos rw, user,noauto 0 0
    also i try
    /dev/da0s1 /mnt/myuser msdosfs rw, user,noauto 0 0

    but i tried:

    mount /mnt/myuser and shows:
    mount_nsdosfs: -o user: option not suported

    and

    mount -t msdos /dev/da0s1 /mnt/myuser nad shows:
    mount_msdosfs: /dev/da0s1: Permission denied

    what else shoud i try???
    or i made a mistake???

    Thanks to all

  5. #5
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    A couple things that don't look right to me...

    Quote Originally Posted by Saltamontes
    -added an user with:
    pw groupmod operator -M myuser
    I don't think this is causing your problem, but I think you wanted 'groupadd' (not 'groupmod'). There should be at least two accounts in operator: root and your user.

    Quote Originally Posted by Saltamontes
    -added rule to /etc/devfs.conf (devfs.rules don't exists)
    So create it! You have to follow the directions, including putting instructions in the right file.

    Give that a try and hopefully you'll be all set. Reboot when finished with the devfs changes. (Or you could restart devfs and add the sysctl MIB manually, but since it's a workstation it is easier to just reboot.)

  6. #6
    Just Joined!
    Join Date
    Oct 2007
    Location
    Mexico
    Posts
    65
    Many days have passed since mi last experiment with FreeBSD, now i come back.

    Thanks anomie, devfs.rules was the mistake.

    After all, FreeBSD is not difficult, some uncommon in the beginning...

    Now im running FreeBSD 7.0 AMD64 with XFCE, audio enabled (debian 4.0R3 with the last kernel dont enable it), MySQL running...(i have some problems with resolution)

    and i have compiled some soft from ports (very easy compared with Linux)

    Thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •