Find the answer to your Linux question:
Results 1 to 5 of 5
Need your help please. When I reboot out of puppy linux to Desktopbsd, the US Robotics 56kUSB serial external modem power light goes off. I'm unable to get DBSD to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Posts
    3

    [SOLVED] kppp can't see /dev/ACM0


    Need your help please.

    When I reboot out of puppy linux to Desktopbsd, the US Robotics 56kUSB serial external modem power light goes off. I'm unable to get DBSD to "see" /dev/ACM0.

    Silent scream after trying unsuccessfully to get kppp to simply dial internet.

    Don't think it's the modem. Downloaded (two days) kubuntu w/ KDE. Was able to dial (as root) internet using kppp. After configuring pppconfig /dev/ttyACM0 and linking /dev/modem to /dev/ttyACM0. It worked.

    Using Desktopbsd, I'm stumped and need your help.

    In addition. When trying to move log files to USB, "Puppy" can't SEE them. But in DBSD, the log files are there.

    Summary:
    Have noticed DBSD lights go off when moving from Puppy to DBSD. No carrier. No DHCP. No modem power light in DBSD.

    Would someone please acknowledge this message and help me.

    J

    P.S. Really need your help on this. If good for you. You can shoot email to:

  2. #2
    Just Joined! wildpossum's Avatar
    Join Date
    Apr 2008
    Location
    Sydney/Australia
    Posts
    92
    As the symbolically linking /dev/modem to /dev/ttyACM0 worked in Linux, then I suspect that Desktop.BSD requires the same type of linkage/ownership.

    As BSD is I think, setout the same as Linux device file system, I would check the devices by:

    " ls -l /dev/* | grep modem " - this should give you the complete data on modem devices available. See if there are any modem devices linked to other devices, and if so remove such a device link, and symbolically link the modem to it as you did under Linux.

    "/sbin/hwinfo > ~/hwnotes.txt" - I am not sure if such a hardware information tool exists under BSD. Hopefully so! Run it and look at the results by "cat ~/hwnotes.txt | less"

    Basically you need to have your modem linked to the device expected to be the actual modem. Be aware that /dev/ttyACMO may not show up as ttyACM0 device under BSD but something else close. If that is the case, you simply need to find that particular device (and that is the one you are needing to symbolically link too hwinfo is the Linux tool to assist you in this, also "dmesg|less" may assist too if it existes under BSD. Otherwise have a look through the syslog log file from the start up point and watch to see that the OS found as available hardware (this need you to have the modem powered on, before you start BSD.

    If I had a detailed view of BSD I certainly would assit more, but I don't.

    Hope this assists you.
    Cheers.

  3. #3
    Just Joined!
    Join Date
    Apr 2010
    Posts
    3
    Firstly, thanks for responding mate.

    Second, the commands you provided didn't work in DBSD. Did:
    tail /var/log/messages ... last line was:
    ugen0 (zero): U.S. Robotics USB modem -- addr 2
    DID:
    ls -l /dev/ugen0
    crw-rw---- 1 root mount
    DID:
    sudo ln -s /dev/ugen0 /dev/modem
    DID:
    lrwxr-xr-x /dev/ugen0 > /dev/modem
    rebooted laptop

    kppp error: "modem is busy" (sorry I'm unable to send actual log files). Haven't figured out how to mount my sandisk USB thumb drive. Puppy doesn't seem to be able to "see" DBSD files on the other side.

    Any other suggestions would be greatly appreciated.

    J

  4. #4
    Just Joined! wildpossum's Avatar
    Join Date
    Apr 2008
    Location
    Sydney/Australia
    Posts
    92

    Red face

    Well your symbolic link from /dev/ugen0 to /dev/modem is correct.
    As I suggested before, this is a BSD specific issue. Apart from executing "lsof | grep modem" and "lsof | grep ugen0" to see what listing of open files relate to the modem &/|| the actual ugen0 device.

    You could also try "cat logfile(the syslog file)" and grep for "ugen0" to see if another device has been assigned automatically, also I would try the following (if the command are available under BSD) "fuser -a /dev/modem" &&/|| "fuser -a /dev/ugen0" which in Linux tells you which processes have opened file descriptors i.e.: the application carried out a "open /dev/modem" system call within. This will assist you in pinning down the problem. I strongly suggest you look at the "man fuser" (in linux) to see what is does and options available, then you maybe able to find the same type of command under BSD by possibly running "man -k fuser" - But that is a guess on my part.

    I don't have much more I can add to help you unfortunately.

    I would sincerely suggest that if the above don't help, its time you seek help from one of the BSD user forums. BSD forums are excellent and you will get someone in little time assisting you I am sure.

    Cheers.
    Last edited by wildpossum; 05-21-2010 at 02:02 AM. Reason: Forgot a important comment I should have made.

  5. #5
    Just Joined!
    Join Date
    Apr 2010
    Posts
    3
    Will try. Thanks for everything.

    My assumption was, I thought 'this' bsd section was for those actually running one of the BSD versions.

    .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •