Find the answer to your Linux question:
Results 1 to 2 of 2
Hey guys. I've been fiddling around trying to install emacs on my solaris 10 test environment. I've picked up emacs and every dependency from sunfreeware.com and everything was installed smoothly. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2012
    Posts
    23

    emacs on solaris 10


    Hey guys. I've been fiddling around trying to install emacs on my solaris 10 test environment.

    I've picked up emacs and every dependency from sunfreeware.com and everything was installed smoothly. However, emacs still complains about one package.

    I ran ldd /usr/local/bin/emacs, and got the list of all used packages.

    libpng.12.so.0 is fine, but just below, I got

    libpng.12.so.0 (PNG12_0) => (version not found)

    How do I solve this? I've been googling around and cannot seem to find anything useful, so I hoped to draw upon you guys' vast experience

    regards,
    Eldamir

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,159
    Well, I run Solaris 10 - x86 on my system (in a VM) and it has emacs installed by default. Doesn't yours? It works fine for me. Ok, regular emacs failed with this error:

    ld.so.1: emacs: fatal: libucb.so.1: open failed: No such file or directory

    However, xemacs works just fine... Go figure! So, try xemacs and see if that works for you, assuming you have the X-Windows server enabled.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •