Hii,

I am new to openbsd. Can someone tell me how to upgrade openssh 4.5 to openssh 5.7 +

Current ssh (4.5) is vulnerable to :
openssh-server Forced Command Handling Information Disclosure Vulnerability

Can you please provide me with some solution to upgrade ssh on openBSD 4.0?

There are nice steps involved here but with these steps, I need to update my ssh linearly like from 4.5 to 4.6 to 4.8 and then apply the patch and then 4.9 till 6.0 version.

OpenSSH for OpenBSD

Last question would be, the above link states the steps to install patch while updating openssh on OpenBSD 4.3, 4.2 or 4.1, Do I need the apply this patch on openBSD 4.0 too ?