Find the answer to your Linux question:
Results 1 to 8 of 8
Hello I cannot change the refresh rate in FreeBSD 5.3 using KDE 3.3 and it's driving me crazy. The screen has black bars all around it and the only way ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User George Harrison's Avatar
    Join Date
    Mar 2005
    Location
    Pepperland
    Posts
    445

    I can't change the refresh rate in FreeBSD


    Hello

    I cannot change the refresh rate in FreeBSD 5.3 using KDE 3.3 and it's driving me crazy. The screen has black bars all around it and the only way to make it go full is to go 800x600 which is just as bad. I've already written to xorgconfig and that did not seem to help. The screen res is just fine, 1024x768 but the refresh rate only has one option which is 75. This is driving me slowly insane. I am really enjoying FreeBSD but if this problem continues I might have to take it off...


    This is a really stupid question but would another WM fix the problem? Is KDE Control Center messing me up? Thanks for any advice/help.
    Registered Linux user #393103

  2. #2
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    You'll need to edit /etc/X11/xorg.conf

    Change the vertical refresh rate and/or horizontal sync rate in that file, and start X again. Sometimes those rates are commented out by default, so you may need to uncomment them. You can find out the value to set these at in the manual for the monitor or online.

  3. #3
    Linux User George Harrison's Avatar
    Join Date
    Mar 2005
    Location
    Pepperland
    Posts
    445
    OK I'm here. I'm too lazy to boot into Slack to use AIM. When I ran "edit /etc/X11/xorg.conf" it gave me an editor and I had no idea what to put in there. When I ran edit "edit less /etc/X11/xorg.conf" it gave me the same editor and I had no idea what to put in there, too. I'm new to this..
    Registered Linux user #393103

  4. #4
    Linux User George Harrison's Avatar
    Join Date
    Mar 2005
    Location
    Pepperland
    Posts
    445
    Same thing in Gnome. When I launch "Screen Resolution Preferences" it'll give me the choice on 1024x768 and below and then it'll stay on 75Hz.
    Registered Linux user #393103

  5. #5
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    Code:
    less /etc/X11/xorg.conf
    when you're in Slack. Scroll down to where it says
    Section "Monitor"
    Note the values it has for vertical sync and horizontal refresh rates. It should look something like this (this is an example from my xorg.conf):
    HorizSync 31.5 - 64.3
    VertRefresh 50.0 - 100.0
    Copy the values down onto a piece of paper or something. Note: your values will be different than mine! Alternatively, you can look up these numbers for your monitor online, but if Slack is configured right, just use the values it's using.

    Boot into FreeBSD and, as root, run
    Code:
    xorgcfg -textmode
    This'll take you to a menu in which you will configure X with all of the appropriate settings. Don't worry about messing up cause you can always start over or edit the file later. After you've written the configuration to /etc/X11/xorg.conf, edit that file and find the part about vertical sync and horizontal refresh. Should look something like:
    Section "Monitor"
    Identifier "Monitor0"
    ### Uncomment if you don't want to default to DDC:
    # HorizSync 31.5 - 64.3
    # VertRefresh 50.0 - 100.0
    Change to:
    Section "Monitor"
    Identifier "Monitor0"
    ### Uncomment if you don't want to default to DDC:
    HorizSync 31.5 - 64.3
    VertRefresh 50.0 - 100.0
    All you're doing is uncommenting. And again, my values will be different than yours. Now try starting X to see if it works.

  6. #6
    Linux User George Harrison's Avatar
    Join Date
    Mar 2005
    Location
    Pepperland
    Posts
    445
    OK thanks.

    I finally broke down and read some of the handbook. I ran under root: Xorg -configure, I then chose to edit it. I saw the same thing (in the monitor section) but the VertRefresh and the HorizSync were not there so I added them and kind of guessed what should be in there on the right. The changes were made and still nothing happened. This is more than likely because I probably entered in the wrong info for the Vert and Horiz stuff but at the same time KDE should at least let me choose another refresh rate other than 75Hz. Eh, I'll look at my config file under Slack.
    Registered Linux user #393103

  7. #7
    Linux User George Harrison's Avatar
    Join Date
    Mar 2005
    Location
    Pepperland
    Posts
    445
    I think I just found the smoking gun. Whenever I boot I get the message: "Could not locate/find config file" then it boots into KDE. I think I'm screwed now..


    Edit: I have actually received this message more than once - it's not because I edited the file. I have seen it before.
    Registered Linux user #393103

  8. #8
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    It'll read /etc/X11/xorg.conf so make sure that file exists. And don't guess vert refresh or horiz sync, just look them up.

    But seriously, just use the Slack config file.

    Xorg on Slack == Xorg on FBSD

    (or so I would hope).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •