Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I'm new to freebsd. After a couple of failed installs, I finally got it up and running. It's so cool and I like it so much. I was trying ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    9

    Help with installing Gimp


    Hi,

    I'm new to freebsd. After a couple of failed installs, I finally got it up and running. It's so cool and I like it so much.

    I was trying to install Gimp through ports and got some error after the install had run for something like 30-45 mins. Here's the output of where the installed ended:

    Code:
    checking GMODULE_LIBS... -Wl,--export-dynamic -L/usr/local/lib -lgmodule-2.0 -lgobject-2.0 -lglib-2.0 -liconv
    checking if GLib is version 2.7.0 or newer... no
    checking for bind_textdomain_codeset... (cached) yes
    checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
    checking for gethostbyname... yes
    checking for connect... yes
    checking for remove... yes
    checking for shmat... yes
    checking for IceConnectionNumber in -lICE... yes
    checking for pkg-config... (cached) /usr/local/bin/pkg-config
    checking for GTK+ - version >= 2.4.4... no
    *** Could not run GTK+ test program, checking why...
    *** The test program compiled, but did not run. This usually means
    *** that the run-time linker is not finding GTK+ or finding the wrong
    *** version of GTK+. If it is not finding GTK+, you'll need to set your
    *** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
    *** to the installed location  Also, make sure you have run ldconfig if that
    *** is required on your system
    ***
    *** If you have an old version installed, it is best to remove it, although
    *** you may also be able to get things to work by modifying LD_LIBRARY_PATH
    configure: error: Test for GTK+ failed. See the file 'INSTALL' for help.
    ===>  Script "configure" failed unexpectedly.
    Please direct the output of the failure of the make command to a file, and
    then feed that file to the gnomelogalyzer, available from
    http://www.freebsd.org/gnome/gnomelogalyzer.sh, which will diagnose the problem
    and suggest a solution.  If - and only if - the gnomelogalyzer cannot solve
    the problem, report the problem to the FreeBSD GNOME team at gnome@FreeBSD.org,
    and attach "/usr/ports/graphics/gimp/work/gimp-2.2.4/config.log" and the
    output of the failure of the make command.  Also, it might be a good idea to
    provide an overview of all packages installed on your system (e.g. an `ls
    /var/db/pkg`).
    *** Error code 1
    
    Stop in /usr/ports/graphics/gimp.
    www# cd /usr/ports/graphics/gimp
    I'm totally clueless what to do next. The install had ended prematurely at different points but I was able to fix those by deinstalling (using make deinstall) the outdated package and reinstalling (using make reinstall) it. But the current one where I'm stuck doesn't seem to have anything to do with an outdated package.

    Please help and thanks in anticipation

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Look to me like you need ton install GTK+ ov version >= 2.4.4.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    9
    Thanks, sdousley

    I got it to work just today. I deleted the old installed GTK and re-installed using ports. After that, I did another make install for Gimp and the installation went successfully.


  4. #4
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    That's cool.

    If u ever get errors like that again, just as a pointer.... usuallt the last line that looks similar to:
    checking for <application name>.....
    is the application you need to install to get it to work... but if u get this again and aren't sure, feel free to posta gain
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  5. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    9
    Hey, sdousley

    I'm slowly getting a hang of things.

    Tried to install clamav (anti-virus) and ran into some problems. clamav required a higher version of libidn and so I deinstalled the existing version of libidn and reinstalled the newer version.

    After that, I could not run kde and related applications because those depended on the deleted version of libidn.

    So I deleled the KDE and reinstalled it via ftp.

    Everything is working fine now and I've a newer version of KDE

    I still don't have clamav but that's okay.

    It has been a very exciting learning journing so far.

  6. #6
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    linux is an exciting journey.

    The reason KDE stopped working is because when u installed it with the old version it would have created certain files.... then when u updated, these files would have changed, so KDE didn't know where they were, then the reinstall used the new versions of the files, meaning it worked
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •