Find the answer to your Linux question:
Results 1 to 7 of 7
I installed cvsup without GUI the other day in FreeBSD as I would like to start thinking about upgrading to 6.0 when it is released so I decided to use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User George Harrison's Avatar
    Join Date
    Mar 2005
    Location
    Pepperland
    Posts
    445

    Having troubles with cvsup and its supfile


    I installed cvsup without GUI the other day in FreeBSD as I would like to start thinking about upgrading to 6.0 when it is released so I decided to use cvsup to synch my sources and stuff. I copied over the example file and I started to edit it, I uncommented all the right stuff like the base and prefix=/usr and stuff and in the host= I put in a cvsup mirror. I uncommented ports-all, and everything like that. Everything seemed to be going perfectly.

    Now when I run the command cvsup -G -l ports-supfile (I'm typing this while not being in front of my *BSD box so if the command isn't right just cut me some slack) and it tells me that I did not specify a release under the host= option. I am truly baffled right now.. when I'm on my test box later I will post the exact stuff but has anyone seen this before? I have Googled and read lots of stuff in the FBSD Handbook, but nothing has come up for me. Thanks for the help.
    Registered Linux user #393103

  2. #2
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    my ports supfile (with comments removed for brevity):
    Code:
    *default host=cvsup17.us.FreeBSD.org
    *default base=/var/db
    *default prefix=/usr
    *default release=cvs tag=.
    *default delete use-rel-suffix
    *default compress
    ports-all
    standard-supfile (tracking RELENG_6):
    Code:
    *default host=cvsup17.us.FreeBSD.org
    *default base=/var/db
    *default prefix=/usr
    #*default release=cvs tag=RELENG_5_3
    *default release=cvs tag=RELENG_6
    *default delete use-rel-suffix
    *default compress
    src-all
    use the following syntax to run cvsup:
    Code:
    cvsup -g -L 1 <supfile>
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    83

    Re: Having troubles with cvsup and its supfile

    Quote Originally Posted by George Harrison
    I installed cvsup without GUI the other day in FreeBSD as I would like to start thinking about upgrading to 6.0 when it is released so I decided to use cvsup to synch my sources and stuff. I copied over the example file and I started to edit it, I uncommented all the right stuff like the base and prefix=/usr and stuff and in the host= I put in a cvsup mirror. I uncommented ports-all, and everything like that. Everything seemed to be going perfectly.

    Now when I run the command cvsup -G -l ports-supfile (I'm typing this while not being in front of my *BSD box so if the command isn't right just cut me some slack) and it tells me that I did not specify a release under the host= option. I am truly baffled right now.. when I'm on my test box later I will post the exact stuff but has anyone seen this before? I have Googled and read lots of stuff in the FBSD Handbook, but nothing has come up for me. Thanks for the help.
    http://www.freebsd.org/doc/en_US.ISO...ook/cvsup.html

    My supfile:

    Code:
    *default tag=RELENG_6
    *default host=cvsup2.uk.FreeBSD.org
    *default prefix=/usr
    *default base=/var/db
    *default release=cvs delete use-rel-suffix compress
    
    src-all
    ports-all

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User George Harrison's Avatar
    Join Date
    Mar 2005
    Location
    Pepperland
    Posts
    445
    ohh ok thanks guys.

    I recall that section and I just uncommented out those stars I also did not have src-all in there. I will try this out as soon as I plug in my ethernet cord and power on my machine thanks again.
    Registered Linux user #393103

  6. #5
    Just Joined!
    Join Date
    Jun 2005
    Posts
    27
    umm, i wouldn't be doing src-all ... this will create dramas

    make sure you only have ports-all

  7. #6
    Linux User George Harrison's Avatar
    Join Date
    Mar 2005
    Location
    Pepperland
    Posts
    445
    Quote Originally Posted by darkprince
    umm, i wouldn't be doing src-all ... this will create dramas

    make sure you only have ports-all
    oh..

    Yeah I did put the src-all but I will remove it at once and sync my sources again. I recall once that I synced the sources but I did "make buildword" and it didn't know how to make. Any specific directory I'm supposed to be in for this? The FBSD Handbook just calls for root, I'm doing this as sudo because I don't really log into root.
    Registered Linux user #393103

  8. #7
    Just Joined!
    Join Date
    Aug 2005
    Posts
    83
    Quote Originally Posted by George Harrison
    Quote Originally Posted by darkprince
    umm, i wouldn't be doing src-all ... this will create dramas

    make sure you only have ports-all
    oh..

    Yeah I did put the src-all but I will remove it at once and sync my sources again. I recall once that I synced the sources but I did "make buildword" and it didn't know how to make. Any specific directory I'm supposed to be in for this? The FBSD Handbook just calls for root, I'm doing this as sudo because I don't really log into root.
    It's /usr/src, and btw Ive never had a problem upgrading with src-all.

    EDIT: I think he thought you wanted to only upgrade ports.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •