Find the answer to your Linux question:
Results 1 to 5 of 5
Hi folks, I have an old machine and always try to install OSS which can squeeze the most out of that machine, so I gave a try to Freesbie, lured ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3

    Problems with Freebie


    Hi folks, I have an old machine and always try to install OSS which can squeeze the most out of that machine, so I gave a try to Freesbie, lured by the FreeBSD foundations. The basic specs are as follows: cpu Celeron 300 Mhz, graphics Nvidia Vanta 16 Mb, 384 Mb of ram, 1st master HD ST 20 Gb and 2nd master HD WD 4.3 Gb. Ok, I got into some troubles. First, while trying to install the system to the 2nd master HD, around at 35%-47% of the process a message appaired: "WARNING -
    WRITE_DMA UDMA ICRC error" and "(retrying request) LBA=" and lots of numbers. It happened 3 times, so I decided to install it anyway. After passing the "configure system" step, another warning came into action:"filesystem table could not be read". I tried to get a look at the error log, but its lenght and the means to read it were quite discouraging, my ignorance made me desist. The drive is almost ok, though, I`ve installed Slackware and Debian on it, no probs with it. Is
    there anything I have to tweak out in the BIOS, kinda LBA, AUTO, LARGE and the likes? Mah, that said I went on to install Freesbie on the 1st master. All fine, then. But after my first boot with the Flubox option, I saw that the screen area was squared with no option to enlarge it; I mean however left or right I pushed the side of the desktop area, still I had a
    black strip. And, first time in my life, the system monitoring widgets on the left were happily camping on the black space.
    On the right top side, the other greenish monitoring visualisation was overlapping the black strip. Think the same of the upper and lower side and you get the picture of a mouse cursor wondering into uncharted lands, lost into the outer space. Also, it seems there's no evidence of Xorg or xorg.conf.
    Boh... is it normal, folks? Another thing to ask about is: how can I streamline this sysem in order to improve performance?
    I understand that Freesbie is a fully loaded big gun, and much better would be to lean on other calibers (kinda going FreeBSD on the bare side). Nevertheless, I would really like to learn a bit of the #BSD world. That to say: I`d need to know where to tweak to load only the essential, how to cut out unneeded services (got no Internet), how to fix the screen
    resolution too `coze the monitor is small and I`m not a lynx, how to set the keyboard to Italian *something went wrong during install). I will look for a guide, meanwhile.
    Hic manebimus optime, folks... thanx for your attention.

    PS. I made a mess. The textfile above was to be saved on a floppy, but I had a struggle with the system because I couldn't mount it; finally I wrote a ******** (/dev/cd0 /cdrom iso9660 ro 0 0) on fstab and saved it WITHOUT MAKING A COPY SOMEWHEER. After the reboot a terrible nemesys appeared: "warning: (all the partitions) was not properly umounted exec mount_iso9660 not found in /sbin:/usr/sbin cannot dunnowhat fstab boot aborted" and it resorted on a shell whose only editor was (sic!) vi. So I tried various livecd to open and deleted the infamous line but whichever mean I used returned the impossibility to save the modification. Now, in fstab all the partitions, so / too, are marked read/write. I managed to save the file by now, but this is a central point: I need not only to make the floppy and the cdrom automounted but also to understand what/why/how etc. etc. That to confirm the real wiseness: You shall not live on Linux only.
    Thanks again


    Ennio

  2. #2
    Just Joined!
    Join Date
    Jun 2005
    Posts
    27
    way too much crap to read there ... you really should post short sharp questiosn in an easy to read format....

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3

    Less crap, then

    the post above is deprecated because I formatted and reinstalled.
    The current problem is to boot in: as I already had a Debian I didn't installed the bootlocks aiming at configuring GRUB, but I can't mount Freesbie's slices.
    What I imput, after reading at "dmesg | tail" is:

    mount -t ufs -o ufstype=ufs2 ro /dev/hdc1 /media/freesbie

    I receive error messages mainly insisting on being the slices read-only and the filesystem wrong.

    What have I to do?

  4. #4
    Just Joined!
    Join Date
    Jun 2005
    Posts
    27
    have a look at fstab the 'ro' in that mount command means 'readonly'

  5. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3
    I did it.

    mount -t ufs -o ufstype=ufs2 /dev/xxx /mnt/freesbie ro (or "default", or "default, ro" as I saw elsewhere) 1 1

    it doesn't work. I also tried an alternative step: using Mandrivain another machine I took advantage of KDE boot manager and I can definetely load Freesbie and boot into it; but when it comes to mounting Linux partitions there's no positive response either. I try to use man instructions to the letter but no results are alleviating my confusion.
    The strange thing (call it crap if you like) is that on my computer I have, among others, Ubunto Linux (on another disk) and Debian. Even if fstab lines are identical Ubunto can mount other partitions and Debian can't (always) do the same.
    Question: does it exist some installation trick, or a program I can use to seal the deal since the beginning?
    I would like to be GUI indipendent, but at least I could learn from the output.

    Contribution welcvome, thanks all

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •