Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
Yup, you need to enable GLX in /etc/X11/xorg.conf (which you said you did) and you need to edit /etc/X11/xorg.conf to use the "nvidia" driver instead of "nv"/"vesa"/whatever, and you need ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431

    Yup, you need to enable GLX in /etc/X11/xorg.conf (which you said you did) and you need to edit /etc/X11/xorg.conf to use the "nvidia" driver instead of "nv"/"vesa"/whatever, and you need to disable "DRI" and friends if you have that turned on.

  2. #12
    Just Joined!
    Join Date
    Aug 2005
    Posts
    83
    Quote Originally Posted by killtehchair
    Quote Originally Posted by the0r3tic
    Quote Originally Posted by killtehchair
    I got this

    Code:
    grant@threeve$ glxinfo|grep accel
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    grant@threeve$
    You basically need drivers for your gfx card then.

    Edit: Oh, well they havent been installed right.
    Any ideas? Uninstall and reinstall from NVIDIA's site or from ports? Is there anything special I need to set them up properly.
    Do not install them from ports, it's alot safer to download from Nvidia.com, they will defintley work then.

  3. #13
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    However, make sure you don't have a legacy card, in that case you need the nvidia legacy driver or an older nvidia driver to function properly.

  4. #14
    Just Joined!
    Join Date
    Jul 2005
    Posts
    40
    Sweet. Thanks guys, booting up the FreeBSD box right now, I'll let ya know how it goes. Hope it goes well

  5. #15
    Just Joined!
    Join Date
    Jul 2005
    Posts
    40
    Woohoo, got it working Thanks a bunch guys . I kept messing with it over and over because I didn't see the NVIDIA splash screen when I loaded Gnome, so I got pissed and kept changing ****, then I just tried it and it worked, lol.

  6. #16
    Just Joined!
    Join Date
    Oct 2005
    Posts
    6
    Any chance you can tell me what change you made that got things working again... I've just lost my Nvidia drivers and I'm having a hell of a time making it work again.

    H

  7. #17
    Just Joined!
    Join Date
    Jul 2005
    Posts
    40
    Quote Originally Posted by hassantm
    Any chance you can tell me what change you made that got things working again... I've just lost my Nvidia drivers and I'm having a hell of a time making it work again.

    H
    IIRC, I uninstalled my drivers, and then reinstalled them from NVIDIA's site. THen in xorg.conf enable GLX

    Code:
    Load       "glx"
    also, make sure the computer is using the NVIDIA drivers instead of the basic "nv" drivers

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •