Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    A couple of OpenBSD questions...

    Ok, i have two questions. My first one is why are all of the packages and ports i install colorless? As in - Simply black and grey. I figured out how to make color in irssi, but not in anything else. (I've not been able to run the programs in X yet, but I think it has color in X)

    and...I almost have xorg configured, but i can't figure out what the mouse device is. It has it set to /dev/wmoused and i can move the mouse but it acts all glitchy. Like, skips across the screen and pastes 'bash' in the terminal over and over again as I move it. So if there is a different device I could try? or some way to fix that, that would be helpful as well.


  2. #2
    Linux User George Harrison's Avatar
    Join Date
    Mar 2005
    1 - Same here, Pork comes out gray instead of the healthy purple like on most systems. Although irssi always came out blue for me the moment I installed the package so that's odd..

    2 - For PS/2 style mice I believe it is /dev/psm0 but don't hold it to me as I have never used GUI in OpenBSD. I used to run Blackbox in FreeBSD but I don't do that anymore.
    Registered Linux user #393103

  3. #3
    Well, I read on the irssi site to do /set term_somethinger_other to make it have color, and that worked. But I have no idea how i would make anything else colorful. In my previous OpenBSD install (didn't last long) I think i remember the apps having color in X. But i'm not sure. As for the mouse device i'll try it as soon as i get X recompiled.

  4. $spacer_open
  5. #4
    Hmm, I recompiled xorg, the one you suggested isn't even a device, and unfortunetly wsmouse is still really buggy-like.

  6. #5
    Ok, xorg is totally functional and I suppose i can live without a little color, so yeah. Problem solved.

  7. #6
    Linux Engineer
    Join Date
    Mar 2005
    IIRC you get colour by setting $TERM to "xterm-color" or something like that

  8. #7
    Yeah the only *BSD that uses a colour TERM is FreeBSD.

  9. #8
    Sorry, i haven't been able to get on for a few days. Does anyone know the exact command to get terminal color back out of X-windows?

  10. #9
    Linux Engineer
    Join Date
    Mar 2005
    In freebsd you can change the color with "vidcontrol", dunno 'bout openbsd. If what the0r3tic states is right (which it probably is), you can't get color in the console. However, try changing between different terminal types (vt100, vt200, pcvt or something like that... I think pcvt is default in freebsd, and vt100 in openbsd)

  11. #10
    As jaboua suggested, set $TERM to xterm-color.
    $ $TERM=xterm-color

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts