Find the answer to your Linux question:
Results 1 to 7 of 7
i added the line "kldload snd_driver" to the /boot/defaults/loader.conf after that my system doens boot ... it prints 2 strangs lines with stuff like .. data = ... text ... ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    5

    ruined loader.conf


    i added the line "kldload snd_driver" to the /boot/defaults/loader.conf

    after that my system doens boot ...

    it prints 2 strangs lines with stuff like .. data = ... text ...

    what shall i do ...

    i dont want to reinstall it ... i have a lot of stuff to worry about

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Try rebooting into a freesbie livecd if you have that, if not you can use the freebsd install cd rescue mode, and mount the root partition (on a one-disk, one-slice ide system, this is /dev/ad0s1a) somewhere. Then you change the loader.conf again, removing the kldload snd_driver statement. Istead, check here what to enter: http://www.freebsd.org/doc/en_US.ISO...und-setup.html

    Maybe you can try something like this:
    Code:
    snd_driver_load="YES"

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Posts
    5
    i got the freesbie ...
    i executed some scripts to mount the FS in Read / Write mode ... but there was some kind of error "invalid fdisk partitiion ... "

    so now i will try the second solution ...


  4. #4
    Just Joined!
    Join Date
    Oct 2005
    Posts
    5

    nothing works

    well nothing works ...
    evrytime i mount ... it tells me " permission denied .."

    i dont beleieve i will reinstall

  5. #5
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    How did you mount it? Did you umount it first in that case?

  6. #6
    Just Joined!
    Join Date
    Oct 2005
    Posts
    5
    yeah ... everything failed .. due to errors in the partition table

  7. #7
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    Boot into single-user mode. You can do this by pressing 4 when you are given the boot options. Press enter when asked which shell to use. This will give you sh, the default. Then fsck your partitions with
    Code:
    # fsck -p
    Then mount your root partition with
    Code:
    # mount -u /
    Though it's not necessary, you might want to mount all other UFS2 partitions with
    Code:
    # mount -a -t ufs
    Turn on swapping (not necessary either, but you might as well) with
    Code:
    # swapon -a
    Now, you must edit /boot/loader.conf. Put this in:
    Code:
    snd_driver_load="YES"
    Now reboot and all should be fixed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •