Find the answer to your Linux question:
Results 1 to 5 of 5
I've just installed FreeBSD 6 and I've got a few problems about how the console works. First of all I've installed bash and I'd like that to be my default ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Posts
    2

    configure console


    I've just installed FreeBSD 6 and I've got a few problems about how the console works.
    First of all I've installed bash and I'd like that to be my default shell for the root account , how do I do that (tried modifying some files but that didn't work ) ?
    Another thing I really dislike is that speraker like beep sound I hear when I'm the cursor won't go any furhter or things like that . How do I disable it ?
    The last thing is that I would like to be able to scroll up and see the messages I get , by default without using less or more . I do that with shift + pgup in Linux , how can I do it in FreeBSD ?
    Thanks .

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    For the first one, you could be a real leet haxxor and edit the last field of /etc/passwd to read /bin/bash.
    Or try
    Code:
    chsh /bin/bash
    as root.

  3. #3
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796

    Re: configure console

    Quote Originally Posted by mforce2
    Another thing I really dislike is that speraker like beep sound I hear when I'm the cursor won't go any furhter or things like that . How do I disable it ?
    This can be done in the inputrc file when you use bash. Google for things like inputrc or maybe readline.

    The last thing is that I would like to be able to scroll up and see the messages I get , by default without using less or more . I do that with shift + pgup in Linux , how can I do it in FreeBSD ?
    Thanks .
    Turn on scroll lock, then you can use pgup/dn or the arrows to move around.

  4. #4
    Just Joined!
    Join Date
    Sep 2005
    Location
    Finland
    Posts
    3
    Just small word of advice. never change bash to root's default shell... for example, if you boot to single user mode you do not have any shell. Why? because freebsd install's bash under /usr and /usr in not mounted in single user mode. for root use sh,csh,tsh, tcsh wich are located under /.

  5. #5
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    Quote Originally Posted by Klamppa
    Just small word of advice. never change bash to root's default shell... for example, if you boot to single user mode you do not have any shell. Why? because freebsd install's bash under /usr and /usr in not mounted in single user mode. for root use sh,csh,tsh, tcsh wich are located under /.
    Actually bash is in /usr/local, and it's not a problem if you move it to /bin or you don't have a seperate /usr (or /usr/local) partition.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •