Find the answer to your Linux question:
Results 1 to 4 of 4
I recently installed FreeBSD 6.0-RELEASE, and I have a couple of very basic questions. First, how do I set up the CDROM drive so that it's mountable/unmountable by regular users, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496

    Mounting CDROM, USB Thumb Drive in FreeBSD 6.0 **SOLVED**


    I recently installed FreeBSD 6.0-RELEASE, and I have a couple of very basic questions. First, how do I set up the CDROM drive so that it's mountable/unmountable by regular users, or (for extra points) so that it automounts on insertion of a disc? Note that I can mount/umount just fine as root. That's not the issue.

    I've looked at my /etc/fstab and the "options" column has ro, noauto. In Linux I simply needed to add users to the end of this column and all was well. In FreeBSD it tells me that "users" is not a valid option.

    I also have a 512MB USB Thumb Drive that I would like to mount. I tried this:
    Code:
    mount_msdosfs /dev/da0 /mnt/usbdisk
    Where /dev/da0 was what showed up in my dmesg output. I got an "invalid option" error.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  2. #2
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    First, how do I set up the CDROM drive so that it's mountable/unmountable by regular users... ?
    Haven't tried this, but I found this article that explains how to enable this:

    http://www.caia.swin.edu.au/reports/041130A/

    The first step is to allow users to run the mount command to actually mount a filesystem and to allow them to run the umount command. This is done by adding the following line to your /etc/sysctl.conf file.

    Code:
    vfs.usermount=1
    ... It is important to note that while setting this variable allows ALL users to run the mount/umount commands to mount and unmount filesystems, mounting and unmounting will only be possible if:

    • The user has read/write permission to the device they wish to mount.
    • The user owns the directory they wish to mount the filesystem to.
    I also have a 512MB USB Thumb Drive that I would like to mount.
    Have you already gone through the handbook steps here?: http://www.freebsd.org/doc/en_US.ISO...usb-disks.html

    If you're still having trouble I will have a look at my usb flash drive and how I got it working. I don't remember having to do anything special (other than what was noted in the handbook).

  3. #3
    Just Joined!
    Join Date
    Jan 2006
    Posts
    2

    Try this and tell me if it worked for you.

    I had the same problems you do.

    I used this for my memorex drive.

    mount_msdosfs /dev/da0s1 /mnt

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by monx
    I had the same problems you do.

    I used this for my memorex drive.

    mount_msdosfs /dev/da0s1 /mnt
    Thanks. That worked. Also thanks to anomie, those quotes from the Handbook helped as well. I supposed I could have RTMed first, but where's the fun in that?
    Registered Linux user #270181
    TechieMoe's Tech Rants

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •