Find the answer to your Linux question:
Results 1 to 2 of 2
I'm being forced to build this port as a dependency of a dependency (of a dependency, ad infinitum it seems) of gnome2. It keeps failing because the patch named bash31-010 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Location
    Maryland
    Posts
    8

    @ bash-3.0 on FreeBSD 6.1-RELEASE


    I'm being forced to build this port as a dependency of a dependency (of a dependency, ad infinitum it seems) of gnome2.

    It keeps failing because the patch named bash31-010 is expected to have a file size of 1829, but has an actual size of 5218.

    I realize the fetch command has a -S flag which is used to verify that the remote file matches some specific size. Is there an easy way for me to edit the fetch command line that's being executed to fetch this particular patch in order to disable that verification?

    I'm trying to build XGL and I really want to play with it!

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Location
    Maryland
    Posts
    8
    I have a quick fix for this, if anyone else is having the same problem.

    in /usr/ports/shells/bash/Makefile:

    remove "10" from the end of this line:
    Code:
    .for patch in        01 02 03 04 05 06 07 08 09 10
    Note: this probably isn't a good idea, because i'm deciding not to apply a patch that someone much smarter than me decided should be applied.

    HOWEVER... it works now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •