Find the answer to your Linux question:
Results 1 to 6 of 6
Hi folks, Ubuntu 7.04 lamp server amd64 Firefox 2.0.0.6 Download RealPlayer10GOLD.bin on RealPlayer site. Performed following steps to get it installed. $ sudo chmod u+x RealPlayer10GOLD.bin $ sudo ./RealPlayer10GOLD.bin The ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814

    Problem to get RealPlayer work


    Hi folks,


    Ubuntu 7.04 lamp server amd64
    Firefox 2.0.0.6


    Download RealPlayer10GOLD.bin on RealPlayer site. Performed following steps to get it installed.


    $ sudo chmod u+x RealPlayer10GOLD.bin
    $ sudo ./RealPlayer10GOLD.bin


    The package was installed on /home/satimis/RealPlayer
    (remark: did not change directory path during installation. Just used default)


    RealPlayer can be started with.
    $ /home/satimis/RealPlayer/realplay


    But it can be evoked on Internet browsing.


    On Firefox;

    Edit -> Preferences -> Contents -> File Types -> Manage -> Change Action
    check "Open them with this application"
    Browse -> realplay


    Reload Firefox
    Still the same. On browsing Internet some sites complain, "install RealPlayer".


    Pls help. TIA


    B.R.
    satimis

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hi - Getting Realplayer to work with Firefox isn't very intuitive. The first thing is to log in as root and locate the following files: nphelix.so and nphelix.xpt . These are the key to making this work.

    They might be in /usr/bin/mozilla but if not log in as root and try: find / -name nphelix.so -print .

    Then you need to know exactly where you installed Firefox ... The key thing is to locate Firefox's plugins directory, and to enter this. For example: cd /home/fingal/firefox/plugins .

    Now you need to create symbolic links to the two files named above. Realplayer's installer won't do this for you: it's a little hopeless! From Firefox's plugin's directory do:

    ln -s /usr/bin/mozilla/nphelix.so (and)
    ln -s /usr/bin/mozilla/nphelix.xpt

    Exit from being root and restart Firefox. Adjust the instructions above to suit your own system / directory tree.

    What you're doing is linking Firefox's plugins directory to the two Realplayer files, so that FF can play streaming media.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    Quote Originally Posted by fingal View Post
    Hi - Getting Realplayer to work with Firefox isn't very intuitive. The first thing is to log in as root and locate the following files: nphelix.so and nphelix.xpt . These are the key to making this work.

    They might be in /usr/bin/mozilla but if not log in as root and try: find / -name nphelix.so -print .

    Then you need to know exactly where you installed Firefox ... The key thing is to locate Firefox's plugins directory, and to enter this. For example: cd /home/fingal/firefox/plugins .

    Now you need to create symbolic links to the two files named above. Realplayer's installer won't do this for you: it's a little hopeless! From Firefox's plugin's directory do:

    ln -s /usr/bin/mozilla/nphelix.so (and)
    ln -s /usr/bin/mozilla/nphelix.xpt

    Exit from being root and restart Firefox. Adjust the instructions above to suit your own system / directory tree.

    What you're doing is linking Firefox's plugins directory to the two Realplayer files, so that FF can play streaming media.
    Hi fingal,


    Tks for your advice.


    $ find / -name nphelix.so -print | grep nphelix.so
    Code:
    ......
    /usr/lib/firefox/plugins/nphelix.so
    /usr/lib/mozilla/plugins/nphelix.so
    /home/satimis/hxsetup/mozilla/nphelix.so
    /home/satimis/RealPlayer/mozilla/nphelix.so

    $ find / -name nphelix.xpt -print | grep nphelix.xpt
    Code:
    ......
    /usr/lib/firefox/plugins/nphelix.xpt
    /usr/lib/mozilla/plugins/nphelix.xpt
    /home/satimis/hxsetup/mozilla/nphelix.xpt
    /home/satimis/RealPlayer/mozilla/nphelix.xpt

    $ ls -al /home/satimis/RealPlayer/mozilla/nphelix.so
    Code:
    -rwxr-xr-x 1 root root 57580 2007-07-27 08:29 /home/satimis/RealPlayer/mozilla/nphelix.so
    $ ls -al /home/satimis/RealPlayer/mozilla/nphelix.xpt
    Code:
    -rwxr-xr-x 1 root root 5086 2007-07-27 08:29 /home/satimis/RealPlayer/mozilla/nphelix.xpt

    $ ls -al /usr/bin/mozilla
    Code:
    lrwxrwxrwx 1 root root 25 2007-07-26 13:56 /usr/bin/mozilla -> /etc/alternatives/mozilla
    $ ls -al /etc/alternatives/mozilla
    Code:
    lrwxrwxrwx 1 root root 16 2007-08-15 21:00 /etc/alternatives/mozilla -> /usr/bin/firefox
    $ sudo ln -s /home/satimis/RealPlayer/mozilla/nphelix.so /usr/bin/mozilla/
    Code:
    ln: accessing `/usr/bin/mozilla/': Not a directory
    I hesitate how to proceed further. Any advice? TIA


    B.R.
    satimis

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hmm that looks horribly confusing and you seem to have a rather complex arrangement there. I think Realplayer (because it's pre-compiled) needs to look in /usr/bin/mozilla ... I'm not familiar with your distro, so I think you need advice from someone who knows Ubuntu.

    Perhaps this would help? I suppose what works on one distro doesn't work on another.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  6. #5
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    Quote Originally Posted by fingal View Post
    Hmm that looks horribly confusing and you seem to have a rather complex arrangement there. I think Realplayer (because it's pre-compiled) needs to look in /usr/bin/mozilla ... I'm not familiar with your distro, so I think you need advice from someone who knows Ubuntu.

    Perhaps this would help? I suppose what works on one distro doesn't work on another.
    Hi fingal,


    Tks for your URL


    I followed "1. Install Automatix2" on following guide installing RealPlayer
    ArsGeek Blog Archive How to get realplayer working in Firefox on Ubuntu 7.04

    It futher referred to;
    Installing Automatix2 with Apt
    Installing Automatix2 on (K,X)Ubuntu 7.04 i386,AMD64 (Feisty)
    Installation - Automatix Wiki


    Steps performed as follow;

    $ echo "deb Index of /apt feisty main" | sudo tee -a /etc/apt/sources.list
    Password:
    Code:
    deb http://www.getautomatix.com/apt feisty main

    $ wget http://www.getautomatix.com/keys/automatix2.key
    Code:
    --18:05:20--  http://www.getautomatix.com/keys/automatix2.key
               => `automatix2.key'
    Resolving www.getautomatix.com... 216.120.255.9
    Connecting to www.getautomatix.com|216.120.255.9|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1,706 (1.7K) [application/pgp-keys]
    
    100%[=====================================================================================>] 1,706          1.59K/s             
    
    18:05:21 (1.59 KB/s) - `automatix2.key' saved [1706/1706]
    $ gpg --import automatix2.key
    Code:
    gpg: directory `/home/satimis/.gnupg' created
    gpg: can't open `/gnupg/options.skel': No such file or directory
    gpg: keyring `/home/satimis/.gnupg/secring.gpg' created
    gpg: keyring `/home/satimis/.gnupg/pubring.gpg' created
    gpg: /home/satimis/.gnupg/trustdb.gpg: trustdb created
    gpg: key E23C5FC3: public key "Arnav Ghosh (Automatix Team Lead) <greyrod@gmail.com>" imported
    gpg: Total number processed: 1
    gpg:               imported: 1

    $ gpg --export --armor E23C5FC3 | sudo apt-key add -
    Code:
    OK

    $ sudo apt-get update
    Code:
    ......
    Fetched 12.3kB in 2s (4879B/s)
    Failed to fetch http://archive.canonical.com/ubuntu/dists/feisty-commercial/Release  Unable to find expected entry  maindeb/source/Sources in Meta-index file (malformed Release file?)
    Reading package lists... Done
    E: Some index files failed to download, they have been ignored, or old ones used instead.

    $ sudo apt-get install automatix2
    It went through w/o complaint


    I used following site to test RealPlayer
    ON24: A World of Webcasting Solutions. One Webcasting Provider

    It further refers to RealPlayer site for testing.

    Test result:-
    Vedio displayed by with following warning
    Code:
    WARNING: Your media player does not allow scripting. Scripting is 
    required for streaming events to perform properly. Please re-install your 
    media player to correct your configuration. 
    
    If you were unable to view the test video,you may want to consider viewing 
    the webcast using an alternative media player. 
    
    If you can see video but you can't hear anything, please check your system   
    volume settings and the volume on the media player.
    
    In order to provide an optimal experience listening to and/or viewing 
    webcasts, we recommend the following media player plug-ins: 
    Windows Media Player 10 or above and RealPlayer 10 or above.
    
    download real player

    B.R.
    satimis

  7. #6
    Just Joined!
    Join Date
    Jun 2004
    Posts
    4

    Years later and...

    Fingal's advice worked perfectly on Slackware 12.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •