Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I am using FC4 (2.6.11-1.1369_FC4) in my intel pentium-3 machine. I have downloaded the xine-ui-0.99.5 and xine-lib-1.1.7. I have installed the xine-lib package mentioned above. But when I am going ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    8

    Exclamation xine player installation problem


    I am using FC4 (2.6.11-1.1369_FC4) in my intel pentium-3 machine. I have downloaded the xine-ui-0.99.5 and xine-lib-1.1.7. I have installed the xine-lib package mentioned above.

    But when I am going to install xine-ui by typing
    ./configure

    the installation aborts saying.............
    Code:
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for style of include used by make... GNU
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking dependency style of gcc... gcc3
    checking for library containing strerror... none required
    checking for gcc... (cached) gcc
    checking whether we are using the GNU C compiler... (cached) yes
    checking whether gcc accepts -g... (cached) yes
    checking for gcc option to accept ANSI C... (cached) none needed
    checking dependency style of gcc... (cached) gcc3
    checking how to run the C preprocessor... gcc -E
    checking for egrep... grep -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking minix/config.h usability... no
    checking minix/config.h presence... no
    checking for minix/config.h... no
    checking for ANSI C header files... (cached) yes
    checking whether make sets $(MAKE)... (cached) yes
    checking for a BSD-compatible install... /usr/bin/install -c
    checking for ranlib... ranlib
    checking whether ln -s works... yes
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking whether NLS is requested... yes
    checking for msgfmt... /usr/bin/msgfmt
    checking for gmsgfmt... /usr/bin/msgfmt
    checking for xgettext... /usr/bin/xgettext
    checking for msgmerge... /usr/bin/msgmerge
    checking build system type... i686-pc-linux
    checking host system type... i686-pc-linux
    checking for ld used by GCC... /usr/bin/ld
    checking if the linker (/usr/bin/ld) is GNU ld... yes
    checking for shared library run path origin... done
    checking for CFPreferencesCopyAppValue... no
    checking for CFLocaleCopyCurrent... no
    checking whether NLS is requested... yes
    checking for GNU gettext in libc... yes
    checking whether to use NLS... yes
    checking where the gettext function comes from... libc
    checking for plural forms in GNU msgfmt... yes
    checking for an ANSI C-conforming const... yes
    checking for inline... inline
    checking for off_t... yes
    checking for size_t... yes
    checking for XINE... Package libxine was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libxine.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libxine' found
    configure: error: Package requirements (libxine >= 1.1.0) were not met:
    
    
    
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    
    Alternatively, you may set the environment variables XINE_CFLAGS
    and XINE_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    Now friends can you help me. Please give detailed instructions.

    Thanks.
    Last edited by devils casper; 09-20-2007 at 06:26 AM.

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    The first thing to do is find out where libxine.pc is installed. To do this you need the find command, so log into your terminal as root then try:

    find / -name libxine.pc -print

    This is asking your system to search through your entire directory tree for the missing file. Let's say you find the file in /usr/local/bin . If so you would configure Xine like this:

    ./configure PKG_CONFIG_PATH="/usr/local/bin"

    You're passing the path of the file to ./configure, and notice the double quotation marks (""). Once you've got the path correct Xine should compile with few problems.

    Once Xine is installed it's worth running xine-check to get some idea of how things went. Xine is a very stable program which I admire, but there are some minor things which will cause it to fail! It's a very good idea to read the documentation here.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    Aug 2007
    Posts
    8

    Doesn't solve the problem

    Thanks but the problem still continues.

    I followed your advice and the response is like that
    Code:
    [root@localhost xine-ui-0.99.5]# find / -name libxine.pc -print
    /usr/local/lib/pkgconfig/libxine.pc
    /root/soft/xine/xine-lib-1.1.7.tar.bz2_FILES/xine-lib-1.1.7/misc/libxine.pc
    find: WARNING: Hard link count is wrong for /proc: this may be a bug in your filesystem driver.  Automatically turning on find's -noleaf option.  Earlier results may have failed to include directories that should have been searched.
    Then I tried
    Code:
    ./configure PKG_CONFIG_PATH="/usr/local/lib/pkgconfig"
    checking for CURL... Package libcurl was not found in the pkg-config search path .
    Perhaps you should add the directory containing `libcurl.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libcurl' found
    *** All of curl dependent parts will be disabled ***
    checking for socket in -lsocket... no
    checking for gethostbyname in -lnsl... yes
    checking for CACA... Package caca was not found in the pkg-config search path.
    Perhaps you should add the directory containing `caca.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'caca' found
    checking whether to have Xft support... yes
    Package xft was not found in the pkg-config search path.
    Perhaps you should add the directory containing `xft.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'xft' found
    Package xft was not found in the pkg-config search path.
    Perhaps you should add the directory containing `xft.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'xft' found
    ***Could not link with Xft. Install Xft if you want support for it***
    checking for LIBPNG... Package libpng was not found in the pkg-config search pat h.
    Perhaps you should add the directory containing `libpng.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libpng' found
    checking for LIBPNG... Package libpng12 was not found in the pkg-config search p ath.
    Perhaps you should add the directory containing `libpng12.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libpng12' found
    configure: error: Package requirements (libpng12 >= 1.2.8) were not met:
    
    
    
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    
    Alternatively, you may set the environment variables LIBPNG_CFLAGS
    and LIBPNG_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    Then I tried this
    Code:
    [root@localhost xine-ui-0.99.5]# find / -name "libpng*.pc"
    find: WARNING: Hard link count is wrong for /proc: this may be a bug in your filesystem driver. Automatically turning on find's -noleaf option.  Earlier results may have failed to include directories that should have been searched.
    Now what to do?
    Last edited by devils casper; 09-20-2007 at 06:25 AM.

  4. #4
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Install the curl-devel and libpng-devel package.

  5. #5
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    I had a thought: I would try to avoid installing the development packages from source as then you'll be involved in dealing with a lot of separate dependencies.

    Just my 10 pence worth.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  6. #6
    Just Joined!
    Join Date
    Aug 2007
    Posts
    8
    I think I could successfully install it. But now I can not run it. It shows the following error

    Code:
    [root@localhost xine-ui-0.99.5]# xine --help
    xine: error while loading shared libraries: libxine.so.1: cannot open shared object file: No such file or directory
    [root@localhost xine-ui-0.99.5]# xine
    xine: error while loading shared libraries: libxine.so.1: cannot open shared object file: No such file or directory
    [root@localhost xine-ui-0.99.5]# xine dvd://VTS_01_1.VOB
    xine: error while loading shared libraries: libxine.so.1: cannot open shared object file: No such file or directory
    Also I want a GUI.

    What to do now?
    Last edited by devils casper; 09-20-2007 at 06:24 AM. Reason: please use [code]...[/code] tags.

  7. #7
    Just Joined!
    Join Date
    Aug 2007
    Posts
    8

    Please answer

    Dear Linux Gurus, don't you know the answer. Let me explain in a bit more details. Pls check the following codes.

    Code:
    [anas@localhost ~]$ xine-check
    Please be patient, this script may take a while to run...
    [ good ] you're using Linux, doing specific tests
    [ good ] looks like you have a /proc filesystem mounted.
    [ good ] You seem to have a reasonable kernel version (2.6.11-1.1369_FC4)
    [ good ] intel compatible processor, checking MTRR support
    [ good ] you have MTRR support and there are some ranges set.
    [ good ] found the player at /usr/local/bin/xine
    [ good ] /usr/local/bin/xine is in your PATH
    [ good ] found /usr/local/bin/xine-config in your PATH
    [ good ] plugin directory /usr/local/lib/xine/plugins/1.1.8 exists.
    [ good ] found input plugins
    [ good ] found demux plugins
    [ good ] found decoder plugins
    [ good ] found video_out plugins
    [ good ] found audio_out plugins
    [ good ] skin directory /usr/local/share/xine/skins exists.
    [ good ] found logo in /usr/local/share/xine/skins
    [ good ] I even found some skins.
    [ good ] /dev/cdrom points to /dev/hdc
    [ good ] /dev/dvd points to /dev/hdc
    [ good ] DMA is enabled for your DVD drive
    [ good ] found xvinfo: X-Video Extension version 2.2
    [ good ] your Xv extension supports YV12 overlays (improves MPEG performance)
    [ good ] your Xv extension supports YUY2 overlays
    [ good ] Xv ports:  YUY2 YV12 UYVY I420 RV15 RV16
    
    [anas@localhost ~]$ xine
    xine: error while loading shared libraries: libxine.so.1: cannot open shared object file: No such file or directory
    
    [anas@localhost ~]$ cd /usr/local/lib
    [anas@localhost lib]$ ls
    gxine       libcdio.so.0      libiso9660.so        libxine.so         pkgconfig
    libcdio.a   libcdio.so.0.0.0  libiso9660.so.0      libxine.so.1       xine
    libcdio.la  libiso9660.a      libiso9660.so.0.0.0  libxine.so.1.17.1
    libcdio.so  libiso9660.la     libxine.la           libxine.so.1.18.0

  8. #8
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    It seems like xine cannot find the libxine libraries. Try the following,
    Code:
    #ln -s /usr/local/lib/libxine* /usr/lib/.
    After that try running xine.

  9. #9
    Just Joined!
    Join Date
    Aug 2007
    Posts
    8
    Quote Originally Posted by daark.child View Post
    It seems like xine cannot find the libxine libraries. Try the following,
    Code:
    #ln -s /usr/local/lib/libxine* /usr/lib/.
    After that try running xine.
    Thank you all. The problem is solved

  10. #10
    Just Joined!
    Join Date
    Oct 2007
    Posts
    4

    xine installation problem

    Hi Friend,

    plz try PKG_CONFIG_PATH=xine-lib-1.1.8 /misc/libxine.pc

    PKG_CONFIG_PATH= -I/usr/include/libpng12

    if not find ..download and add to /usr/include/

    Thanks & Regards,
    Venkii.M

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •