Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, Running freespire (debian based---<--- i think). I have a 9700pro AIW, installed latest drivers from ATI, all went well. Have installed ET(AS ROOT ??) now when i go to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    14

    Can't load enemy territory...


    Hi,

    Running freespire (debian based---<--- i think).
    I have a 9700pro AIW, installed latest drivers from ATI, all went well. Have installed ET(AS ROOT ??) now when i go to run ET, well there is a script file called et which i run(i am guessing here but it looks right) anyway i get a bit of stuff in the console but this is where is error is,

    Code:
     You are using software Mesa (no hardware acceleration)!
     Driver DLL used: libGL.so.1
     If this is intentional, add
           "+set r_allowSoftwareGL 1"
     to the command line when starting the game.
    ***********************************************************
    ...WARNING: could not set the given mode (4)
    Initializing OpenGL display
    ...setting mode 3: 640 480
    Using XFree86-VidModeExtension Version 2.2
    XFree86-VidModeExtension Activated at 640x480
    Received signal 11, exiting...
    any ideas?

    I had ET working fine before when i had a 5200fx installed( i have since reinstalled linux though) BUt i haven't fiddled with anything in linux though.

    What i think,

    1) should i have installed ET as root, does this matter ?
    2) It must be to do with the graphic card driver...

    TIA for any help...

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Posts
    14
    I just read on another forum that i shouldn't install as root, so will install ETt again as main user, although i have no idea how to uninstall the first ET, though i guess it can just sit there, will install ET (2) to a new directory ??

    So it looks like the default software emulated MESA drivers are set to run the game. How do i have the ATI drivers set to run it as the ATI drivers seemed to install fine when i installed them. Is there something else i need to do here..?

    TIA

    EDIT:

    In my xorg.conf this is all there is for the graphics card, which doesn't look right after looking at other conf's on the net,

    Section "Device"
    Identifier "Device1"
    Driver "fglrx"
    Option "UseInternalAGPGART" "no"
    BusID "PCI:1:0:0"
    EndSection

    Section "Device"
    Identifier "Device2"
    Driver "fglrx"
    Option "UseInternalAGPGART" "no"
    BusID "PCI:1:0:1"
    EndSection

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Posts
    14
    tried a fglrxinfo and it look like all is set to mesa, any idea how to fix this,

    Code:
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    display: :0.0  screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •