Find the answer to your Linux question:
Results 1 to 2 of 2
I have recently installed quake3 1.32 to play online ( after 3 year without playing it ^^ ). Like many people with 2.6 kernel and alsa, I doesn't get any ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Posts
    7

    quake3 and sound freezing ?


    I have recently installed quake3 1.32 to play online ( after 3 year without playing it ^^ ).
    Like many people with 2.6 kernel and alsa, I doesn't get any sound, as well with oss compatibility.

    I tried the echo trick we can find online :
    Code:
    echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
    echo "quake3.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
    This works, I get sound in menus and if I start a single player map...
    but if I connect to a server ( internet or local ), game hangs up when I spawn in the map. I can kill the game for any console, it doesn't freeze the system.

    If I don't enable sound with echo trick, the game never freezes.

    What could crash oss emulation ?

    The modules "snd_seq_oss", "snd_pcm_oss", "snd_mixer_oss" and so on are loaded, my sound card is part of the ULi M1695 chipset ( it's a AC97 ) in an Asrock 939dual-sata motherboard, detected with snd-intel8x0 's module.
    ( I know there is a fix for via based sound cards, but that trick doens't work for my chipset. )

    I am running kernel 2.6.23.1 and alsa 1.0.14.


    NB: I have tried ioquake3 ( v1.34 ), but it is not a solution for me because I want to play online.

  2. #2
    Just Joined!
    Join Date
    Dec 2007
    Posts
    1
    Try running it with the music volume set to -1, like so:

    quake3 +set s_musicvolume -1

    I had the exact same problem and this seems to have cleared it right up.
    I got it from a gentoo linux wiki
    You might also want to check out the punkbuster section at the bottom of the page.
    I added the echo statements to my /etc/rc.local file so I don't have to type it again. this might not be a Good Idea but oh well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •