Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Hello, as I said already in the title I have laptop Compaq Armada 7800, the series 6300/T/8000/V/0/3 and I tried several Linux distributions (BeaFanatIX, Debris, DSL, GoblinX, Puppy, Wolvix, Arch ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    5

    Question No sound-card detected on Compaq Armada 7800


    Hello,
    as I said already in the title I have laptop Compaq Armada 7800, the series 6300/T/8000/V/0/3 and I tried several Linux distributions (BeaFanatIX, Debris, DSL, GoblinX, Puppy, Wolvix, Arch Linux) on it and I have got no sound although there is a working integrated sound-card on that laptop.

    I tried:
    Code:
    amixer:
    Mixer attach default error: No such device
    
    similar answer with alsamixer
    I also tried to search for any sound-card and it found none.

    My questions are:
    Q0: Where is the problem: am I missing drivers, some kernel modules, or what?

    Q1: I guess that I am missing some drivers but I have no idea where to get them from. Is there such place? And what drivers should I install?

    Q2: Is there some sort of "universal driver" which can solve this problem?

    Q3: Extreme solution: The sound used to work when Windows was on that laptop. Can I get the sound working somehow through the WINE?

  2. #2
    Just Joined!
    Join Date
    Apr 2008
    Posts
    5

    Smile Sort of solution

    I found solution to simillar problem on
    Sound Drivers for Compaq Armada 7800 - LinuxQuestions.org

    I will go and try it.

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    5

    Still not working

    I tried several things, but the thing is still not working.
    Some more technical details:

    Code:
    augustin@wolvix ~ $ lcpci
    bash: lcpci: command not found
    Code:
    augustin@wolvix ~ $ lsmod
    Module                  Size  Used by
    ipv6                  259744  10 
    sg                     32040  0 
    capability              7436  0 
    commoncap               9344  1 capability
    fuse                   44564  1 
    agpgart                33352  0 
    lp                     14120  0 
    psmouse                40096  0 
    xirc2ps_cs             20636  1 
    serial_cs              24460  1 
    pcmcia                 35756  2 xirc2ps_cs,serial_cs
    evdev                  12288  4 
    yenta_socket           28444  5 
    rsrc_nonstatic         15244  1 yenta_socket
    shpchp                 34336  0 
    pcmcia_core            38716  5 xirc2ps_cs,serial_cs,pcmcia,yenta_socket,rsrc_nonstatic
    ata_generic             9480  0 
    pata_triflex            8964  0 
    irtty_sir               9476  0 
    sir_dev                14980  1 irtty_sir
    parport_pc             28772  1 
    parport                35144  2 lp,parport_pc
    ns558                   8704  0 
    irda                  117176  1 sir_dev
    crc_ccitt               6016  1 irda
    pcspkr                  6656  0 
    gameport               15624  2 ns558
    serio_raw               9476  0
    Code:
    augustin@wolvix ~ $ amixer   
    amixer: Mixer attach default error: No such device
    augustin@wolvix ~ $ alsamixer
    
    alsamixer: function snd_ctl_open failed for default: No such device
    Code:
    augustin@wolvix ~ $ aplay            
    ALSA lib confmisc.c:769:(parse_card) cannot find card ''
    ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
    ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
    ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_concat returned error: No such device
    ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
    ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned error: No such device
    ALSA lib conf.c:3982:(snd_config_expand) Evaluate error: No such device
    ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM default
    aplay: main:545: audio open error: No such device
    Code:
    augustin@wolvix ~ $ /sbin/lspci
    00:00.0 Host bridge: Compaq Computer Corporation Northstar (rev 01)
    00:00.1 PCI bridge: Compaq Computer Corporation Northstar (rev 01)
    00:0c.0 CardBus bridge: Texas Instruments PCI1250 (rev 02)
    00:0c.1 CardBus bridge: Texas Instruments PCI1250 (rev 02)
    00:0e.0 ISA bridge: Compaq Computer Corporation CETUS-L (rev 03)
    00:0e.1 IDE interface: Compaq Computer Corporation Triflex Dual EIDE Controller (rev 01)
    00:0e.2 USB Controller: Compaq Computer Corporation ZFMicro Chipset USB (rev 11)
    01:00.0 VGA compatible controller: S3 Inc. ViRGE/MX (rev 06)
    Any idea?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2008
    Posts
    7
    Augustin,

    I'm working my way through a stack of Compaq laptops that I'm trying to refurbish for an NPO in Philly. I have 5 of the Armada 7800. That link you posted earlier had some really useful info from Peacedog. One thing is for sure, the sound card uses the ISA bus and I'm fairly certain it's an ESS1879. That means it should use the snd-es18xx module for ALSA. If you were thinking of using an OSS module, forget it. From what I can see, it doesn't exist. That's probably why DamnSmall didn't work for you (what I'm using for this project). I will have to install ALSA to get the modules I need.

    I'm still learning how to deal with ISA PnP/non-PnP sound cards in Linux. From what I've learned so far you basically need to add a few parameters when loading the kernel module(s). Since they're ISA-based, the main parameters of interest will be things like port, irq, dma1, dma2, mpu_port, etc. Do a 'modinfo snd-es18xx' so all the parameteres. You should be read those parameters from the BIOS, if you can even acces it.

    I won't be able to get physical access to the laptops again for about another week. I just wanted to let you know I'm working on it too and I'll let you know if I get anywhere.

  6. #5
    Just Joined!
    Join Date
    Apr 2008
    Posts
    5
    Hi,
    thanks for reply

    I tried the ALSA driver but it didn't work for me. I do not know why...

    Augustin

  7. #6
    Just Joined!
    Join Date
    May 2008
    Posts
    7
    Quote Originally Posted by Augustin View Post
    I tried the ALSA driver but it didn't work for me. I do not know why... Augustin
    Have you tried passing any parameters to the module when it loads? If so, what ones?

    Are you able to see any kind of sound card settings in the BIOS (irq, dma, io, etc.) ? I won't be able to look around mine until I make a RomPaq floppy. I'm hoping the settings are visible so I'll know what to use as module parameters.

  8. #7
    Just Joined!
    Join Date
    Apr 2008
    Posts
    5
    No I haven't. I just did:

    Code:
    modprobe snd-es18xx

  9. #8
    Just Joined!
    Join Date
    May 2008
    Posts
    7
    Hey, I just tried the OSS sound blaster module (sb) under DSL and got a loud screeching noise. I can't test it any further tonight because everyone is asleep. But I believe all I have to do is turn down the mic before loading the module and everything should be fine. I got the idea from this link. btw, i did not pass it any parameters.

  10. #9
    Just Joined!
    Join Date
    May 2008
    Posts
    7
    I was able to do more testing today. Just wanted to let you know, the OSS sb module is certainly the winner with the Armada 7800. I also found that I had to pass the the irq parameter, in my case irq=5. So loading the module looked like this:
    Code:
    sudo modprobe sb irq=5
    I can't test it using ALSA yet. If you give either one a try, let me know how it goes. I have about 8 more of this same model to configure later. btw, you may want to plug in headphones for testing, at least until you can must mute the mic. The feedback noise is intense.

  11. #10
    Just Joined!
    Join Date
    May 2008
    Posts
    2
    I too was having trouble with the sound on an Armada 7800 (es1879).
    Found the solution on the Compaq/HP website.
    The snd-es18xx mod is looking for a pnp expansion card that doesn't exist because it's onboard.
    Use snd-es1688.
    Go here, Compaq Armada 7800 Notebook PC series and select your model.
    On the resulting page go down to >Resources>>Manuals.
    About 11 links down will be a .pdf for Linux installation although it is dated.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •