Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
When I go to a page with Flash content I get the usuall "Additional Plugins needed" message, for example: http://www.adobe.com/products/flash/about/ . In a few years time with Linux and Firefox, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    20

    Firefox Adobe Flash Player plugin simply does not work. Help!?


    When I go to a page with Flash content I get the usuall "Additional Plugins needed" message, for example: http://www.adobe.com/products/flash/about/. In a few years time with Linux and Firefox, I have never been able to get Firefox to display flash content like this. I have tried installing the plugin in a couple of ways. 1: Clicking the "Install Missing Plugins" link. This claims to have installed the plugin but nothing changes. 2: Downloading the package from http://www.adobe.com/go/getflashplayer and insterting libflashplayer.so into the following directories: /usr/local/bin/firefox/plugins/ and /home/<username>/.mozilla/plugins/. I checked and changed to permissions on both files to see if it helped, but it didn't.

    More recently I learned to check aboutlugins, which shows that the only plugin I have installed is libnullplugin.so even though libflashplayer.so is clearly in the plugins directory. I am currently running Firefox 2.0.0.17. Please give any advice you have.

  2. #2
    Just Joined!
    Join Date
    Oct 2008
    Posts
    29
    Same problem with me. When I open any page containing flash content, firefox asks me to install the plugin, but when I try to install it, it says it's already installed.

  3. #3
    Just Joined!
    Join Date
    Oct 2008
    Posts
    20
    What version of Firefox are you using? Look in Help->About Mozilla Firefox.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2008
    Posts
    20
    You can try manually installing Adobe Flash. Goto http://www.adobe.com/go/getflashplayer and select *.tar.gz to download. Extract the downloaded file and it should make a folder. Enter the folder and execute flashplayer-installer. Open a terminal and type the following commands assuming you downloaded into your home directory.

    Code:
    cd /home/<username>/
    tar -zvxf install_flash_player_10_linux.tar.gz
    cd install_flash_player_10_linux
    ./flashplayer-installer

  6. #5
    Just Joined!
    Join Date
    Oct 2008
    Posts
    29
    I am using firefox 3.0.3 . The flash player is already installed but still not working.

  7. #6
    Just Joined!
    Join Date
    Oct 2008
    Posts
    29
    Was able to install flash, but after installation, firefox is crashing constantly(With gmail)

  8. #7
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Make sure you do not have a native flash player like Gnash, I think having more than one plugin handler is asking for trouble.
    Open your browser and type this into the address bar to make sure that Adobe Flash Player is listed as a plugin.
    Code:
    about:plugins
    Also, make sure you have Java installed, unless you do not want it for some reason.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  9. #8
    Just Joined!
    Join Date
    Oct 2008
    Posts
    20
    I've tried several methods of installing the Adobe Flash Player plugin, but aboutlugins still shows that I have no plugins installed except libnullplugin.so . libflashplugin.so is in my ~/firefox/plugins/ directory along with libnullplugin.so but apparently isn't being detected. So I tried installing Java just to see what would happen.

    Java download:
    http://javadl.sun.com/webapps/downlo...BundleId=25051
    Installation instructions:
    How do I download and install Java for my Linux computer? - 1.5.0, 6.0
    Just as with Adobe Flash, I put libjavaplugin_oji.so into ~/firefox/plugins/ except I did it as a symbolic link as instructed, and it worked. Java shows up under aboutlugins and the http://www.java.com/en/download/help/testvm.xml applet works just fine.

    So why does libjavaplugin_oji.so work while libflashplayer.so isn't even detected? I have no idea. If it is a compatibility issue, I need to know what my system is missing that I need to install or what alternative flash player I can use that will actually work.

    Atom: You might need to try running firefox from a terminal to see if it gives any info when it crashes. Run the command 'xterm' and type in 'firefox' in the window. If firefox starts up let it crash and see if there is any error output in the window.

  10. #9
    Just Joined!
    Join Date
    Oct 2008
    Posts
    29
    I am running it from terminal, but no error message is seen. It's working fine if I disable flash plugin.

  11. #10
    Just Joined!
    Join Date
    Oct 2008
    Posts
    20
    New information!

    Linux Headquarters: Using the Flash Plugin with 64-bit Firefox
    This page explains that the Adobe Flash Plugin is a 32-bit plugin and that if you happen to have the 64-bit version of Firefox it will be incompatible. The 64-bit Firefox may have been installed if you have a 64-bit processor. If this is the problem, the solution is to either follow the instructions to install nspluginwrapper which will allow the usage of 32-bit plugins, or install the 32-bit version of Firefox.

    How do I find out what bit version of Firefox I am using?

    Adobe Flash Player for Linux Info
    This page gives some tips about how to get Flash to work for linux. It explains a possible reason that the player will crash Firefox, so Atom may want to take a look at that part. Among other things this page says Adobe Flash Player 10 (the plugin in question) requires glibc-2.4 or higher. I am in the process of trying to install glibc-2.4 (I have a former version,) but another solution is to install Adobe Flash Player 9 instead, which apparently doesn't have that particular dependency. I just need to find where to download it.

    I hope these new clues help either of us or any readers with the same problem. I will update as soon as I try any of the solutions.

    Edit: Adobe Flash Player 9 is detected but causes Firefox to crash when the is Flash content in a page. There is something about libstdc++ in the error output.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •