Find the answer to your Linux question:
Results 1 to 3 of 3
I have an ati radeon all in wonder 9000 pro. I have debian linux. Ntohing seems to work when it comes to getting opengl to work. The ati drivers dont ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    1

    ati opengl


    I have an ati radeon all in wonder 9000 pro. I have debian linux. Ntohing seems to work when it comes to getting opengl to work. The ati drivers dont work, They install without problems, but my softwrae seems to still ber using mesa. Iv found another site, the second on google. It was conmfusing, and even follwing its intructrions didn;t help. I found an automated install script, and it didnt help either.

    Is there anyhting else i can do?

  2. #2
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    the current ati drivers are only for Xfree3.x and there are currently none for Xfree4.x making that most likly your problem. I hear that people have created workarounds to this, but I cannot offer much more untill ATI gets there act together and releases new drivers.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Quote Originally Posted by qub333
    the current ati drivers are only for Xfree3.x and there are currently none for Xfree4.x making that most likly your problem. I hear that people have created workarounds to this, but I cannot offer much more untill ATI gets there act together and releases new drivers.
    Actually there are drivers for Xfree 4.3.x NOT 4.4.x. Also Xorg 6.7.x NOT 6.8.x.

    Once you install the ati-drivers, you have to modprobe fglrx. Then you can run fglrxconfig to create a new XF86Config-4 for you (be sure to back up your old one in /etc/X11 before you overwrite it). Change any settings that you had edited in your old XF86Config in the new one (basically do a manual merge of the two files) and start up X. All should be working well.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •