Find the answer to your Linux question:
Results 1 to 10 of 10
So I've been playing 3.0 no problem but I started playing WoW again a few days ago. The patch downloaded just fine and everything but now every time I boot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    10

    Unhappy World of Warcraft 3.0.8


    So I've been playing 3.0 no problem but I started playing WoW again a few days ago. The patch downloaded just fine and everything but now every time I boot I get a fatal error crash and it brings up the blizzard error reporter. Does 3.0.8 not work yet through wine? I was using 1.1.13 but i tried going down to 1.1.12 to see if that would work but I got the same results.

  2. #2
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    2,003
    This should work no problem but try this:

    wine Wow.exe -opengl

    from terminal and see if it spits out any errors
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    10
    wine: could not load L"C:\\windows\\system32\\Wow.exe-opengl": Module not found

    hmm thats what i get

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2009
    Posts
    10
    Ah I think I know what my problem is but I'm not sure of how to fix it. I have my .WTF file set to opengl, but when i carefully read the error message it says my settings are set to SET "direct3d" but i open my .WTF and it still says its set to opengl, so im not sure where its pulling its config from now...? weird

  6. #5
    Just Joined!
    Join Date
    Jan 2009
    Posts
    10
    haha i tried running it off the install I have on my NTFS external HDD all i did was went into the config.WTF and switched it to opengl and now it works but it wont work when i have it on my actual hard drive lol

  7. #6
    Just Joined!
    Join Date
    Jan 2009
    Posts
    1
    sorry to hijack your post but im cusrious as to how your WOW performs. I am using ubuntu and I am getting 24 to 27 fps on it compared to my xp which gets 60 to 80 fps. I tried following all the instructions i get on the net like setting the .wtf to opengl.

    Are there some other configurations that i need to do to make it work better? This is the only reason why i still have xp on my machine.

    Many thanks.

    btw, my system has an intel e6550 and ati 4950 with 4g of ram, maybe theres some tweaking with the drivers that you guys may know.

    again many thanks

  8. #7
    Just Joined!
    Join Date
    Jan 2009
    Posts
    10
    I actually have the exact opposite results. I have a vista/ubuntu machine with a q6600 nvidia geforce 9600gt 4gb of ram and on vista I can run anywhere from 30-60fps (depending on how busy my server is and if im in a big city or not) and when im on ubuntu i can go from about 40-100fps. My only issue is that my sound does not work when i run WoW in ubuntu. But I'm not sure what you can do to make your performance better sorry

  9. #8
    Just Joined!
    Join Date
    Dec 2006
    Posts
    5
    I cant believe blizzard are too lazy to release a linux WoW anyway, it cant be that hard.

    rsf01: I thought ati drivers for linux were useless anyway? maybe thats why your framerate is so low, you will just have to boot into XP to play it.

  10. #9
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by lovefist233 View Post
    I cant believe blizzard are too lazy to release a linux WoW anyway, it cant be that hard.

    rsf01: I thought ati drivers for linux were useless anyway? maybe thats why your framerate is so low, you will just have to boot into XP to play it.
    In the past, ATI drivers for Linux were woefully inadequate. I can't speak from personal experience (haven't owned an ATI card in years) but I've been told that recent efforts have brought it up to near feature-parity with their Windows drivers.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  11. #10
    Just Joined!
    Join Date
    Dec 2006
    Posts
    5
    The last I heard was that if you had an ATI card you could just forget about linux gaming, that said, I haven't owned an ATI card for years either, I got fed up of the drivers being so unstable and at the time nVidia were the best

    Still, it wouldnt kill blizzard to release a linux version of WoW, theres one for EvE Online, although I hear that the eve client is written in Python

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •