Find the answer to your Linux question:
Results 1 to 5 of 5
I am slightly addicted to the game Worms World Party. I know it old, but it IS a great game. I am using Mandriva 2008.1 KDE 3.5 I successfully (I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197

    Worms World Party


    I am slightly addicted to the game Worms World Party. I know it old, but it IS a great game.
    I am using Mandriva 2008.1 KDE 3.5
    I successfully (I think) installed WWP using CrossOver Professional 7.1.0. I also installed the patch necessary to run the game. (Team 17 published a game that doesn't work, you need to install a patch for it to work, even on Windows machines.)
    I am using a win2000 bottle for this.
    Anyway, there are two issues:
    1. It doesn't work. When I try to run it it says "insert cd", so I do. Then when I try to run it it changes the resolution to 640x480, and then gets stuck. Nothing happens.
    Here is the output from the konsole:
    Code:
    wine: Unhandled page fault on read access to 0x0000073c at address 0x7e378582 (thread 001a), starting debugger...
    Process of pid=0019 has terminated
    No process loaded, cannot execute 'echo Modules:'
    Cannot get info on module while no process is loaded
    No process loaded, cannot execute 'echo Threads:'
    process  tid      prio (all id:s are in hex)
    00000008
            00000009    0
    0000000c
            00000015    0
            00000014    0
            00000013    0
            0000000e    0
            0000000d    0
    0000000f
            00000012    0
            00000011    0
            00000010    0
    00000016
            00000018    0
            00000017    0
    You must be attached to a process to run this command.
    No process loaded, cannot execute 'detach'
    2. Provided I can get it to work, I would like to run it off a mounted ISO file. When I was using Vista, I had a virtual box running 2000 in which I had installed WWP and Virtual Clone Drive, which would mount an ISO. That worked (surprisingly) well. It ran much faster that way, I didn't need to bother with the cd.
    Now, when I mounted the ISO file, it didn't recognize it. It said to insert cd.

    The first point is more crucial, we'll deal with the second one later.
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

  2. #2
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,991
    HOWTO: Worms World Party under Linux - Team17 Forum

    Details on how to get it to work
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  3. #3
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197
    Thanks but I have seen that thread before, I checked up on this before I started my own thread.
    In this case, I have a successful install on Linux, using CrossOver. I did the DLL thing (I only had to delete that one DLL, I already had the other one), and it still doesn't work.
    I got the exact same output to the Konsole as last time.
    Any more suggestions?
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

  4. #4
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    I can't really help you with your WINE problem (although I agree WWP is a fun game). There is a game that's similar to Worms that runs natively on Linux. It's called Wormux. If it's not available on the Mandriva repositories, you can try their main site here:

    en/index - Wormux
    Registered Linux user #270181
    TechieMoe's Tech Rants

  5. #5
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197
    I have tried Wormux. It is a nice game, but you can't play against the computer. The only thing it has going for it are the team and player names.
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •