Find the answer to your Linux question:
Results 1 to 4 of 4
I, too, have been looking for a GB emulator recently. I downloaded both GNUBoy and VisiualBoyAdvance. I don't know how to run GNUBoy (typing gnuboy into the terminal doesn't work ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Raize's Avatar
    Join Date
    Jan 2009
    Location
    Colorado, USA
    Posts
    28

    GameBoy emulator


    I, too, have been looking for a GB emulator recently. I downloaded both GNUBoy and VisiualBoyAdvance. I don't know how to run GNUBoy (typing gnuboy into the terminal doesn't work and I can't find it in the menus). VBA seems to have been installed properly, but I don't know where to find ROMs.

  2. #2
    Linux Newbie sdimhoff's Avatar
    Join Date
    Jan 2007
    Posts
    191
    In terms of ROMS, I can't help you. In my own emulation experience, I've never had to look too hard to find ROMS.

    Did you just download it from their site? If so then you will have to make it executable. The one I see for linux will be called SDL-Test

    chmod +x SDL-Test

    Then you can run it:

    ./SDL-Test

    When I tried it, I initially got an error with my X server, but I never looked at what dependencies were needed so I wasn't that concerned. It looks like it also needs the libglademm library. After I got that it worked fine. Also, just downloading something will not put it in your menu.

    If, instead, you got it from your repository (apt-get, portage, yast, etc.) then it will generally get the necessary dependencies and also place the program in your menu, but not always. If you got it through your repository, just search for the executable and you can run it from the command line or put it into your menu manually

    (locate or slocate depending on the system)
    The executable should be called gvba or VisualBoyAdvance. To find these files:

    # locate gvba | grep bin
    or
    # locate VisualBoyAdvance | grep bin

    Happy playing!
    Linux since: 2001
    Gentoo since: 2004
    - - - - - - - -
    Translation:
    I fix things until they break.

  3. #3
    Just Joined! Raize's Avatar
    Join Date
    Jan 2009
    Location
    Colorado, USA
    Posts
    28
    Code:
    debian:/# locate gvba | grep bin
    bash: locate: command not found
    debian:/# slocate gvba | grep bin
    bash: slocate: command not found
    debian:/# find / -xdev -iname gvba
    debian:/# find / -xdev -iname visualboyadvance
    /usr/bin/VisualBoyAdvance
    /usr/share/VisualBoyAdvance
    /usr/share/doc/visualboyadvance
    debian:/#
    When I try to run it using that path, it gives me this:
    Code:
    Missing image name
    /usr/bin/VisualBoyAdvance [option ...] file
    I am assuming, of course, that I am supposed to type the name of the ROM file, which I don't have.

  4. #4
    Just Joined! kahlil88's Avatar
    Join Date
    Jul 2009
    Location
    Mendocino, CA
    Posts
    25
    It's illegal to download ROMs if you don't own the original game, but they're not hard to find. I suggest installing visualboyadvance-gtk which is a GUI for the emulator.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •