Find the answer to your Linux question:
Results 1 to 5 of 5
I downloaded Planeshift, and did the Chmod +x thing, and then ran the installer...perfect, no problems...until I tried to run Planeshift. When I click (or double-click) the icons, nothing happens, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    3

    Planeshift HELP!


    I downloaded Planeshift, and did the Chmod +x thing, and then ran the installer...perfect, no problems...until I tried to run Planeshift. When I click (or double-click) the icons, nothing happens, nothing at all. But when I type the command into the Terminal I get this:

    /opt/PlaneShift/psclient
    Your configuration files are in... /root/.PlaneShift
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    ERROR: FATAL: Cannot open X display
    WARNING: failed to initialize plugin 'crystalspace.window.x'
    Could not create an instance of crystalspace.window.x!
    WARNING: failed to initialize plugin 'crystalspace.graphics2d.glx'
    Error loading Graphics2D plugin.
    WARNING: failed to initialize plugin 'crystalspace.graphics3d.opengl'
    DEBUG: Initializing OpenAL sound system
    DEBUG: Retrieving available devices.
    DEBUG: Default OpenAL device: '((sampling-rate 44100) (device '(native))
    DEBUG: No device specified
    DEBUG: Falling back on default device
    ALSA lib conf.c:3952snd_config_expand) Unknown parameters 0,0
    ALSA lib pcm.c:2202snd_pcm_open_noupdate) Unknown PCM default:0,0
    DEBUG: Can't retrieve attributes size: OpenAL error ALC_INVALID_DEVICE
    No 3D driver!
    psclient: No 3d driver (iGraphics3D) plugin!


    I know that I have my graphic drivers installed, I've played other games, like nexuiz and even Regnum on this laptop. I have a Toshiba Satellite with ATI Radeon graphics, not sure what card, but I could check if necessary. I am usin SuSE 11.1 With Gnome. Please! Any help would be very appreciated.
    P.S. I am kind of a linux noob, have had it for a long time, but still don't know how to do much, im one of those 'copy-paste commands from the internet' people.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    I'm not familiar with it but if the configuration files are installed to your root directory then I'm assuming the game was installed as root. Try installing it as your regular user and run that way and not as root. Running progs as root in SuSE (and many other distro) won't allow you to run X-windows.
    Linux Mint + IceWM Registered:#371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    3

    hmm

    Well when I installed it as user...the same thing happened, but I can try it again, it won't take long.

  4. #4
    Just Joined!
    Join Date
    May 2009
    Posts
    3

    ugh

    Now when I click the uninstaller, it doesn't work....It wont even let me uninstall it >_<

  5. #5
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    It appears to me you were attempting to run it as root. Otherwise it wouldn't call on configuration files in your root directory when attempting to run. After installation (as root) did you attempt to run it as root or as regular user?
    Linux Mint + IceWM Registered:#371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •