Find the answer to your Linux question:
Results 1 to 3 of 3
After I recently upgraded my flash plugin, I can't get my sound to work; for example the command aplay /usr/share/sounds/purple/send.wav gives the error ALSA lib pcm.c:2202 snd_pcm_open_noupdate) Unknown PCM eq ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    10

    Help needed: upgraded flash plugin - now sound doesn't work!


    After I recently upgraded my flash plugin, I can't get my sound to work; for example the command

    aplay /usr/share/sounds/purple/send.wav

    gives the error

    ALSA lib pcm.c:2202snd_pcm_open_noupdate) Unknown PCM eq
    aplay: main:590: audio open error: No such file or directory

    As far as I know, all modules are correctly loaded; I even did a reboot just to make sure. Does anybody know what's going on here, and how I can get my sound back? FWIW, I'm using Arch Linux (I've also asked this question on the Arch forums, but as that's a smaller community I might not get a reply), on an old IBM Thinkpad T42. Up until this flash upgrade, I had no trouble with sound.

    Any advice or ideas would be most welcome!

    Thanks,
    -A

  2. #2
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Don't know Have you tried reconfiguring alsa?

    as root
    alsaconfig

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,159
    Have you tried removing the plugin to see if that fixes the audio problem? I assume you have rebooted the system? Also, check the mixer to see if the PCM level is not set off.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •