Find the answer to your Linux question:
Results 1 to 9 of 9
As the title says, How do I get a share on my fileserver added to the storage group of mythbuntu across the network? Any Help Appreciated... ~MP...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142

    mythtv adding smb share to storage group.


    As the title says, How do I get a share on my fileserver added to the storage group of mythbuntu across the network?

    Any Help Appreciated...

    ~MP

  2. #2
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    878
    What server. If it's running some POSIX OS then I'd use NFS.

  3. #3
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142
    It's a samba share I don't want want to setup a nfs server when my samba server is already established for past two years.

    CENTOS 5.3

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    878
    NFS server will not affect your existing SAMBA server. There is absolutely no reason why the very same volume couldn't be shared via SAMBA, NFS, AFP, FTP, HTTP, etc.

  6. #5
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142
    is this the only way to get it in mythtv?

    Because I need to be able to add it to my storage group in mythtv.

    if so, how do I go about it?

  7. #6
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    878
    It's not the only way, altough in my opinion NFS is much easier to set up than SAMBA. And NFS is the native way for POSIX systems.
    You add it to MythTV as you add local directories.

  8. #7
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142
    so I setup the nfs on my fileserver and mount the share to a directory on mythbuntu but now I can't delete the recordings.

  9. #8
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    878
    Something is gone south with permissions. Remember, permissions in NFS do not follow username, they are determined by UID instead. Did you use NFSv3 or NFSv4? Also make sure export options in export file are what you need them to be. man exports

  10. #9
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142
    I figured it was permissions but instead of trying to set them on a directory in /

    I just re-mount it to the default directory for myth at /var/lib/mythtv/recordings and now it works fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •