Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all, I have been trying and trying but I just can't get it BACK to work. I worked. I wanted to get my Microphone to work. And now its ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429

    No Sound in Linux Mint.


    Hello all,

    I have been trying and trying but I just can't get it BACK to work. I worked. I wanted to get my Microphone to work. And now its broke.. :/
    I always have problems like this..

    Here is my aadebug info:
    Code:
    ALSA Audio Debug v0.1.0 - Fri Jul 24 22:25:59 CEST 2009
    http://alsa.opensrc.org/aadebug
    http://www.gnu.org/licenses/gpl.txt
    
    Kernel ----------------------------------------------------
    Linux Twix 2.6.28-13-generic #45-Ubuntu SMP Tue Jun 30 19:49:51 UTC 2009 i686 GNU/Linux
    
    Loaded Modules --------------------------------------------
    snd_ca0106             39968  3 
    snd_ac97_codec        112292  1 snd_ca0106
    snd_pcm_oss            46336  0 
    snd_mixer_oss          22656  1 snd_pcm_oss
    snd_pcm                82948  4 snd_ca0106,snd_ac97_codec,snd_pcm_oss
    snd_seq_dummy          10756  0 
    snd_seq_oss            37760  0 
    snd_seq_midi           14336  0 
    snd_rawmidi            29696  2 snd_ca0106,snd_seq_midi
    snd_seq_midi_event     15104  2 snd_seq_oss,snd_seq_midi
    snd_seq                56880  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
    snd_timer              29704  2 snd_pcm,snd_seq
    snd_seq_device         14988  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
    snd                    62628  15 snd_ca0106,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    snd_page_alloc         16904  2 snd_ca0106,snd_pcm
    
    Dev Snd ---------------------------------------------------
    controlC0  midiC0D0  pcmC0D0c  pcmC0D0p  pcmC0D1c  pcmC0D1p  pcmC0D2c  pcmC0D2p  pcmC0D3c  pcmC0D3p  seq  timer
    
    CPU -------------------------------------------------------
    model name	: AMD Athlon(tm) 64 Processor 3200+
    cpu MHz		: 2010.280
    
    RAM -------------------------------------------------------
    MemTotal:        1026564 kB
    SwapTotal:       2104504 kB
    
    Hardware --------------------------------------------------
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
    01:00.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
    I run MINT Linux not Ubuntu.
    I tested my sound like this:
    Code:
    robin@Twix ~/music/ $ mplayer -ao alsa Lamb\ of\ god\ -\ Sacrament\ -\ 00\ -\ Walk\ With\ Me\ In\ Hell.mp3 
    MPlayer 1.0rc2-4.3.3 (C) 2000-2007 MPlayer Team
    CPU: AMD Athlon(tm) 64 Processor 3200+ (Family: 15, Model: 79, Stepping: 2)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    
    Playing Lamb of god - Sacrament - 00 - Walk With Me In Hell.mp3.
    Audio file file format detected.
    Clip info:
     Title: Walk With me in Hell
     Artist: Lamb of God
     Album: Sacrament
     Year: 
     Comment: 
     Genre: Unknown
    ==========================================================================
    Forced audio codec: mad
    Opening audio decoder: [libmad] libmad mpeg audio decoder
    AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
    Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
    ==========================================================================
    AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
    Video: no video
    Starting playback...
    Cannot sync MAD frame 314.0 (05:14.0)  1.2% 
    Cannot sync MAD frame
    Cannot sync MAD frame 314.0 (05:14.0)  1.2% 
    A: 309.1 (05:09.1) of 314.0 (05:14.0)  1.2% 
    
    Exiting... (End of file)
    Anywho, I used alsamixer to turn everything way up. But, no luck..

    If anyone has points I'd love to hear from you. Also I can open a SSH or Remote Desktop system so you can just take control and try...

    Any advice/tips/docs or thigns to check..?

    Thanks

    Robin
    New Users, please read this..
    Google first, then ask..

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,574
    Do you also have pulse audio installed? If so, remove it and try to reinstall ALSA.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429
    Its fixed by now.
    Turned out I just messed something up with the settings.
    Still havnt mangerd tog et the Input to work though.

    (fixed: /etc/init.d/alsa<something> reset 0)
    New Users, please read this..
    Google first, then ask..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •