Find the answer to your Linux question:
Results 1 to 8 of 8
Hi ! first my system: 2.6.8 kernel ati radeon 9500 xorg 6.7 ati-driver 3.9.0 i have the newest Mesa installed, but when i try to install tuxracer i get this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie robak's Avatar
    Join Date
    Jan 2004
    Posts
    136

    problems with tuxracer


    Hi !

    first my system:
    2.6.8 kernel
    ati radeon 9500
    xorg 6.7
    ati-driver 3.9.0

    i have the newest Mesa installed, but when i try to install tuxracer i get
    this messages:

    ./configure --prefix=/home/nurbs/Tuxracer --with-gl-libs=/usr/local/lib
    --with-gl-inc=/usr/local/include/GL/ --enable-stencil-buffer *

    loading cache ./config.cache
    checking for a BSD compatible install... /bin/install -c
    checking whether build environment is sane... yes
    checking whether make sets ${MAKE}... yes
    checking for working aclocal... found
    checking for working autoconf... found
    .
    .
    .
    checking for GLU library... yes
    checking for GL/gl.h... yes
    checking for GL/glx.h... yes
    checking whether glx.h defines glXGetProcAddressARB... no
    configure: error: Your copy of glx.h is out of date. *You can get a more
    recent copy from the latest Mesa distribution
    (http://mesa3d.sourceforge.net).


    what can i do?
    thx in advance
    greez robak
    make install not love

    Registered Linux user number 369245

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    What distro are you using? Is there not a package available precompiled? I was also under the impression (could be wrong here) that ATI and NVidia had their own versions of the GL libraries, so you wouldn't want to use the Mesa Libs.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Linux Newbie robak's Avatar
    Join Date
    Jan 2004
    Posts
    136
    i have gentoo, and tuxracer installed
    but i downloaded the sources because i want to develop the game myself.
    i wanted to code antialiasing and such stuff.
    make install not love

    Registered Linux user number 369245

  4. #4
    Just Joined!
    Join Date
    Oct 2004
    Posts
    15
    I know for sure glXGetProcAddressARB in configure's script shoul dbe changed to somehting else... I'm still trying to find what...

  5. #5
    Just Joined!
    Join Date
    Oct 2004
    Location
    Belgium, Kamp City
    Posts
    1
    try replacing glXGetProcAddressARB with glXGetProcAddress. it worked for me

  6. #6
    Linux Newbie robak's Avatar
    Join Date
    Jan 2004
    Posts
    136
    big thanks for your posts !

    configure works now
    but i get hundreds of warnings while compiling

    Code:
    make
    
    .
    .
    .
    game_config.c:798:37: pasting "." and "write_diagnostic_log" does not give a valid preprocessing token
    game_config.c: In function `register_game_config_callbacks':
    game_config.c:1159: warning: passing arg 3 of `Tcl_CreateCommand' from incompatible pointer type
    game_config.c:1160: warning: passing arg 3 of `Tcl_CreateCommand' from incompatible pointer type
    make[2]: *** [game_config.o] Error 1
    make[2]: Leaving directory `/home/nurbs/tuxracer/tuxracer-0.61/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/nurbs/tuxracer/tuxracer-0.61'
    make: *** [all-recursive-am] Error 2
    behind every command i get the message
    Code:
    does not give a valid preprocessing token
    what does this mean?
    make install not love

    Registered Linux user number 369245

  7. #7
    Just Joined!
    Join Date
    Oct 2004
    Posts
    15
    I don't know man but I'm getting the same problems with Slack10.0... I'm rgretting the upgrade from Slack 9.1... everything worked like a charm in it!

    Any help would be appreciated... I'm sure this is a distro-specific problem... but even the Slack10.0 tuxracer packages won't work!!!! Compiling is Slack10.0 users' only hope can you please post any information that might be helpful to us.

    Thank you very very much in advance!

  8. #8
    Just Joined!
    Join Date
    Oct 2004
    Posts
    15
    Ok! I found a solution to the tuxracer installation error in Slackware... here is the solution

    http://www.ati.com/support/infobase/4687.html

    BTW.... this is only for those who wish to install the precompiled packages...
    You want to download the slack tuxracer package or even tuxkart and use installpkg command to install them... they will work after following the guide at that site.
    I still can't compile the program for some odd reason. Well... one problem solved... another to go.


    Shashir was here -- This is a tag not a signature.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •