Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Trying to install " sh NVIDIA-Linux-x86-185.18.31.pkg1.run" file. Everytime I try I get an error " cant open sh NVIDIA-Linux-x86-185.18.31.pkg1.run" This is what the Nvidia site says to use as the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2009
    Posts
    8

    Cant install Nvidia driver in terminal. Cant open error


    Trying to install " sh NVIDIA-Linux-x86-185.18.31.pkg1.run" file.

    Everytime I try I get an error " cant open sh NVIDIA-Linux-x86-185.18.31.pkg1.run"

    This is what the Nvidia site says to use as the command. The site I got it from is below.

    nvidia.com/object/linux_display_ia32_185.18.31.html

    What am I doing wrong here. In the meantime I will search the net and forum.

    Thanks

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    You must run this command from the same directory that the file is in. For example, if the file is in /home/bigkiddos/saves then you need to cd to that directory
    cd /home/bigkiddos/saves
    sh NVIDIA-Linux-x86-185.18.31.pkg1.run
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You also must first stop the Xserver. How you do this depends on your distro version. Then you must also have root permissions to install the driver.

    When you ask for help, you should give some information on the system that the help is for.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2009
    Posts
    8
    Quote Originally Posted by waterhead View Post
    You also must first stop the Xserver. How you do this depends on your distro version. Then you must also have root permissions to install the driver.

    When you ask for help, you should give some information on the system that the help is for.
    sorry about that. I am trying out Linux Ultimate edition 2.3 right now.

    I typically save all the files to my desktop then delete them after I install them.

  6. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    OK, Linux Ultimate seems to be based on Ubuntu. If it uses Ubuntu commands, I can give you some detailed help.

    First, to compile a kernel driver, you need to install a few things.

    linux-source (kernel source)
    linux-headers (kernel headers)
    build-essential (Ubuntu megapackage that will install many needed programs)
    gcc (Linux C compiler)

    I don't know exactly what LU uses to manage package installation, so you will need to figure out how to install the needed programs.

    You then need to stop the xserver. It looks as if it is using the KDE desktop, so enter this command into a terminal window.
    Code:
    sudo /etc/init.d/kdm stop
    You then need to go to a terminal, so use this key combination:

    Ctrl+Alt+F1

    Press these keys in that order, and hold them down until you have all three pressed. You should get a screen that is a blinking curser, asking for you to log in. Log in as your normal user, then you can go to the folder that has the nVidia diver file in it.
    Code:
    cd /home/<username>/file_location
    Then, when you run the installation file, use the sudo prefix to give you root privileges.
    Code:
    sudo sh NVIDIA-Linux-x86-185.18.31.pkg1.run
    Make sure you answer the questions (accept the legal BS), and allow it to look for a precompiled version. It will then compile the driver. Also let it configure the xorg.conf file.

    Then reboot, and hope for the best!
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #6
    Just Joined!
    Join Date
    Aug 2009
    Posts
    8
    Hi Waterhead thanks for the help. I installed the things you listed. Stopped xserver. That went fine.

    I then went into Terminal using Ctrl alt delete.

    This is the error I got:

    -Bash: CD no file or directory

    mike@mike-desktop:~$

    Your bios does not provide ACPI_PSS objects in a way linux understands. Please report to linux and your bios vendor.

    I then looked at my bios and it says "ACPI Suspend type S1&S3 Enabled".
    or I can select S1 (pos) or S3 (str)

    I definately need a linux command book!!

  8. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The cd command should be in small letters. It is shorthand for change directory. It is followed by a space, and then the entire path to the folder that you want to go to.

    The other errors that you got seem like a hardware compatibility problem. Since it mentions the BIOS, a BIOS update might fix things. BUT, an unsuccessful BIOS upgrade will turn your computer into a brick! So be aware of the potential bad results.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #8
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    If this is based of ubuntu, you should be able to install the driver from the repository instead of compiling your own. The package should be called nvidia-glx-*. You can determine which is the newest by opening a terminal and executing these codes:
    Code:
    apt-cache search nvidia-glx
    The newest one will end with a higher number, then install it with
    Code:
    sudo apt-get install nvidia-glx-xxx
    Replace xxx with the number of the latest driver. After this we just need to edit the xorg.conf file, can you post the contents of it?

  10. #9
    Just Joined!
    Join Date
    Aug 2009
    Posts
    8
    Well I was told that the driver in the synaptic package manager was an older version driver and it would not run right with my video card because it is a newer card. My card is a XFX GTS 250 card. I also got rid of Ulitmate Edition because a friend of mine said that UE had to much junk installed I dont need and it could be conflicting so now I am running linux mint.

    I got the driver package to install thanks to you guys, but I get a error when I start it that says :

    "Running in low graphics mode". then I have to revert back to the original settings. Not even desktop effects can be enabled.

    I tried updating the xconfig file and it seems like it worked. I found that info from other people having the same problem on the net. I restart the X server and when i restart it gives me a error after reboot that says something like:

    Running in low graphics mode
    "(EE) NVIDIA 0-Failed to initialize nvdia kernel module systems kernel log for additional error messages & consult nvidia readme. Aborting.Screens found but none have a usable configuration.

  11. #10
    Just Joined!
    Join Date
    Aug 2009
    Posts
    8
    Quote Originally Posted by coopstah13 View Post
    If this is based of ubuntu, you should be able to install the driver from the repository instead of compiling your own. The package should be called nvidia-glx-*. You can determine which is the newest by opening a terminal and executing these codes:
    Code:
    apt-cache search nvidia-glx
    The newest one will end with a higher number, then install it with
    Code:
    sudo apt-get install nvidia-glx-xxx
    Replace xxx with the number of the latest driver. After this we just need to edit the xorg.conf file, can you post the contents of it?
    Hi,

    is this the file you need? I see a couple of them with a number. But this one just says xorg.conf.

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder63) Tue Jul 28 16:20:20 PDT 2009

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 28.0 - 33.0
    VertRefresh 43.0 - 72.0
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    # generated from default
    EndSection

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    EndSection

    Section "ServerFlags"
    Option "DontZap" "False"
    EndSection
    ----------------------------------------------------------------

    I also have another one that says xorg.conf shows the most current "modified" time/date:

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder63) Tue Jul 28 16:20:20 PDT 2009

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 28.0 - 33.0
    VertRefresh 43.0 - 72.0
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    # generated from default
    EndSection

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    EndSection

    Section "ServerFlags"
    Option "DontZap" "False"
    EndSection

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •