Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
guys! my story: i wanted to play games[especially battlefield]under linux. that's why i got cedega over shareaza[i know,this means warez]. it sucked all the times,giving me error=21. meanwhile i was ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Nov 2004
    Location
    Hungary
    Posts
    1

    cedega debian


    guys!

    my story:

    i wanted to play games[especially battlefield]under linux.
    that's why i got cedega over shareaza[i know,this means warez].
    it sucked all the times,giving me error=21.
    meanwhile i was reading forums,but no useable help i found.

    and then..somebody wrote,that using auto instead of vfat in /etc/fstab
    helps.

    and it did.it did not quit with errormessage,but returned prompt.
    i thought that directory names with space in then makes this prob.

    go to the dir,and guess what..

    only works for root,starting new X[startx -- :1]..

    i'm gonna get it working for users,for sure..

    this is cool..
    i'm gonna register at transgaming..

  2. #12
    Just Joined!
    Join Date
    Nov 2004
    Posts
    1
    Hi there
    Im using winex instead of cedega (updated), and I have the very same error that leper khan have, but only if I lauch wine from winex directory (wine /mnt/cdrom/setup.exe).
    If I try to run from the image drive (from a iso file mounted) I got this
    __________________________________________________ _____________________
    [root@localhost imgdrv]# wine setup.exe
    err:dosmem:setup_dos_mem Cannot use first megabyte for DOS address space, please report
    fixme:keyboard:X11DRV_KEYBOARD_DetectLayout Your keyboard layout was not found!
    Using closest match instead (Brazilian ABNT-2 keyboard layout) for scancode mapping.
    Please define your layout in windows/x11drv/keyboard.c and submit them
    to us for inclusion into future Wine releases.
    See the Wine User Guide, chapter "Keyboard" for more information.
    fixmerender:X11DRV_XRender_Finalize Free cached glyphsets
    err:dosmem:setup_dos_mem Cannot use first megabyte for DOS address space, please report
    fixme:keyboard:X11DRV_KEYBOARD_DetectLayout Your keyboard layout was not found!
    Using closest match instead (Brazilian ABNT-2 keyboard layout) for scancode mapping.
    Please define your layout in windows/x11drv/keyboard.c and submit them
    to us for inclusion into future Wine releases.
    See the Wine User Guide, chapter "Keyboard" for more information.
    fixmesdrv:PSDRV_BITMAP_SelectObject stub
    fixmesdrv:PSDRV_BITMAP_SelectObject stub
    fixmesdrv:PSDRV_BITMAP_SelectObject stub
    wine: Unhandled exception, starting debugger...
    err:seh:start_debugger Couldn't start debugger ("programs/winedbg/winedbg -- --auto 3 96") (2)
    Read the Wine Developers Guide on how to set up winedbg or another debugger
    fixmerender:X11DRV_XRender_Finalize Free cached glyphsets
    __________________________________________________ _____________________

    that is the same error I got running from the cd
    this keyboard stuff never was a real problem, this last line bout "fixmerender:X11..." really irritates me but I don't think it's a problem either (besides, can someone tellme what is that??) so, the "psdrv:PSDRV_BITMAP" looks my real problem...

    I made a winecheck and I only have a non-existent toolbar (problaby because I install without a windows instalation present on my system).
    So, is that information enough to you help me?

  3. #13
    Just Joined!
    Join Date
    Jan 2005
    Posts
    1
    to Leper Khan and others with similar probs:

    try the following command as root:

    echo 1 > /proc/sys/vm/legacy_va_layout

    the file above had a "0" on it by default.
    I don't know what the hell it does and honestly i don care. The truth is it worked and that is fine for me.

    best regards;

    Orph

  4. #14
    Just Joined!
    Join Date
    Nov 2004
    Posts
    12
    Quote Originally Posted by Orpheu
    to Leper Khan and others with similar probs:

    try the following command as root:

    echo 1 > /proc/sys/vm/legacy_va_layout

    the file above had a "0" on it by default.
    I don't know what the hell it does and honestly i don care. The truth is it worked and that is fine for me.

    best regards;

    Orph
    I've got the same issue. The problem with the suggested solution I have is that I have to be logged in as root to execute it. As soon as I log out I have error 21 again. However, if I try to launch a programme under root, I have another error, something like:

    Code:
    lib: connection to ":0.0" refused by server
    Xlib: No protocol specified
    xterm Xt error: Can't open display: :0.0

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •