Find the answer to your Linux question:
Results 1 to 1 of 1
i have been trying to set up 3d hardware acceleration (i think i need opengl or something...)i had mesa-glx installed...i dont know if that gives 3d hardware acceleration or not, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    85

    3d hardware acceleration on Intel Corporation 82945G/GZ Integrated Graphics (fixed)


    i have been trying to set up 3d hardware acceleration (i think i need opengl or something...)i had mesa-glx installed...i dont know if that gives 3d hardware acceleration or not, but when i installed compiz it removed that one and replaced it with nvidia-glx(even though i dont have an nvidia card...or maybe i did that i dont remember...its been a while) when that broke it i uninstalled it and installed mesa-glx but its never worked since... well it seems virtual box need it (or more specifically ragnarok online in virtual box needs 3d acceleration) but i have no idea how to set it up for this card.
    i have seen tons of things for setting up opengl with nvidia or ati cards, but to my knowledge i have neither.
    lspci gives:
    00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
    lspci -n gives:
    00:02.0 0300: 8086:2772 (rev 02)

    my xorg.conf is pretty bare:
    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Module"
            load "glx"
    EndSection
    
    Section "InputDevice"
            Identifier      "Generic Keyboard"
            Driver          "kbd"
            Option          "XkbRules"      "xorg"
            Option          "XkbModel"      "pc104"
            Option          "XkbLayout"     "us"
    EndSection
    
    Section "InputDevice"
            Identifier      "Configured Mouse"
            Driver          "mouse"
    EndSection
    
    Section "Device"
            Identifier      "Configured Video Device"
            Option          "UseFBDev"              "true"
    EndSection
    
    Section "Monitor"
            Identifier      "Configured Monitor"
    EndSection
    
    Section "Screen"
            Identifier      "Default Screen"
            Monitor         "Configured Monitor"
    EndSection
    i added the glx module section when last i was trying to get this to work...needless to say i was unsuccessful...i think i added that option to the configured video device too...

    glxinfo gives:
    Code:
    name of display: :0.0
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual
    
       visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
     id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x73 32 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    austin@debian:~$ glxinfo
    name of display: :0.0
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual
    
       visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
     id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x73 32 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    before the ordeal with compiz that did work...(btw compiz never did work)
    ive googled, ive irc'd, i tried everything i know...but i have no idea what its doing, and to be honest im not entirely convinced i have any idea what IM doing...

    so any help would be greatly appreciated.
    --edit---
    i did get 3d acceleration working, i was sure i uninstalled nvidia-glx, but when i went into kpackage i seen it there so i uninstalled it and everything with the word nvidia in it.
    i also ran Xorg -configure to get a more recognizable xorg.conf...

    unfortunately ragnarok online still isnt working -_-
    Last edited by the_ultimate_samurai; 02-10-2010 at 02:19 AM. Reason: fixed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •