Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
So, I've had this problem ever since I upgraded to Xubuntu 9.10 and even after switching to Debian. (9.04 was fine.) Basically, all manner of sound is broken. Using ALSA ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2009
    Posts
    24

    Unhappy All sound broken - ALSA underrun


    So, I've had this problem ever since I upgraded to Xubuntu 9.10 and even after switching to Debian. (9.04 was fine.) Basically, all manner of sound is broken.

    Using ALSA or Pulse, any program that plays sound will skip and stutter every few seconds. Imagine a CD you found in a parking lot. All display "ALSA underrun" in the terminal when this happens.

    Using OSS, the skipping is less frequent (2-3 times per minute), but still enough to be a bother. Video is basically unwatchable as both mplayer and VLC will, in addition to the skipping problem, just stop playing sound entirely after between 1 and 30 minutes.

    The amount of skipping depends largely on the file format. FLAC and OGG skip so badly they're almost unrecognizable. MP3 is not as bad, but still useless. WAV plays almost flawlessly, but skips more often under heavy CPU load. In all cases there also seems to be more skipping at some times than others (wait an hour, a day, etc and it'll be more, or less). It's as if the decoders are not getting enough CPU time.
    All players exhibit the same behaviour: the progress jumps several seconds visually as the sound skips. So the problem has to be in decoding.

    mpd would skip terribly even on OSS until adding this line to .mpdconf:
    Code:
    use_nmpa        "yes"
    with that it only skips a few times per minute, like other programs, but it's still bothersome, and with OSS nothing else can play sound at the same time. (Notably, the Flash player locks up the entire browser. -.-)

    An even bigger issue comes with trying to watch any sort of video. VLC skips too (image is fine), displaying a message:
    Code:
    [0x876a810] alsa audio output error: cannot write: Broken pipe
    After a few minutes (between 1 and 30), VLC will stop playing sound entirely. mplayer (with video or just audio files) will freeze up and start repeating the last sample EXTREMELY LOUD. x.x

    Right now I'm on Debian Squeeze kernel 2.6.32-trunk-686, MPD version 15.8, ALSA version 1.0.21; single AMD Sempron CPU about 1600mhz; 1GB RAM which is about half full.

    This has gone on for about a month and nobody seems to have any solution. Surely someone must know what's going on with this?

  2. #2
    Just Joined! Shannon_VanWagner's Avatar
    Join Date
    Aug 2007
    Location
    Seattle
    Posts
    5
    I was having performance issues with my Realtek ALC1200 embedded sound with Ubuntu Karmic 9.10

    $ cat /proc/asound/card0/codec#* |grep Codec
    Codec: Realtek ALC1200

    Finally I found a fix... I modified the last line in /etc/modprobe.d/alsa-base.conf with the text below and rebooted ( added options: model=6stack-dig and position_fix=1 ):
    options snd-hda-intel power_save=10 power_save_controller=N position_fix=1 model=6stack-dig

    Here's more details on my hardware for comparison:
    $ lspci |grep Audio
    00:09.0 Audio device: nVidia Corporation MCP73 High Definition Audio (rev a1)

    $ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: NVidia [HDA NVidia], device 0: ALC1200 Analog [ALC1200 Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: NVidia [HDA NVidia], device 1: ALC1200 Digital [ALC1200 Digital]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    So now the "crunchiness" has gone away, and the sound doesn't go to mute
    everytime I reboot and log back in.

    So hopefully something here can help you.

    Regards,

    Shannon VanWagner
    humans(-)enabled

  3. #3
    Just Joined!
    Join Date
    Jun 2009
    Posts
    24

    Smile

    That seems to have fixed mplayer, but hasn't helped MPD at all.

  4. #4
    Just Joined! Shannon_VanWagner's Avatar
    Join Date
    Aug 2007
    Location
    Seattle
    Posts
    5
    Can you post the output from the following commands?

    cat /proc/asound/card0/codec#* |grep Codec

    lspci |grep Audio

    aplay -l

  5. #5
    Just Joined!
    Join Date
    Feb 2008
    Posts
    3
    Are you relying on "integrated" sound? When I first started using Linux about 8yrs ago, a Linux specialist retailer told me that I would need to install a soundcard as the integrated sound on the hardboard would not work with Linux. After installing one, the sound worked perfectly and on subsequent desktops I've continued to have a seperate soundcard installed and have been rewarded with excellent sound from whatever OS I use.

  6. #6
    Just Joined!
    Join Date
    Jun 2009
    Posts
    24

    Post

    I have a PCI C-Media sound card that worked fine until the upgrade.

    Code:
    $ cat /proc/asound/card0/codec#* |grep Codec
    cat: /proc/asound/card0/codec#*: No such file or directory
    
    $ lspci |grep Audio
    
    $ aplay -l 
    **** List of PLAYBACK Hardware Devices ****
    card 0: CMI8738 [C-Media CMI8738], device 0: CMI8738 [C-Media PCI DAC/ADC]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: CMI8738 [C-Media CMI8738], device 1: CMI8738 [C-Media PCI 2nd DAC]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: CMI8738 [C-Media CMI8738], device 2: CMI8738 [C-Media PCI IEC958]
      Subdevices: 1/1
      Subdevice #0: subdevice #0

  7. #7
    Just Joined! Shannon_VanWagner's Avatar
    Join Date
    Aug 2007
    Location
    Seattle
    Posts
    5
    Does your machine have a proprietary modem driver installed via System>Administration>Hardware Drivers? If so, try removing it - because it's a known bug that it may be stepping on your sound.

  8. #8
    Just Joined!
    Join Date
    Jun 2009
    Posts
    24
    I'm not sure how to access the hardware drivers dialog in Xfce, but I don't have a modem at all, so I'm guessing no.

  9. #9
    Just Joined!
    Join Date
    Apr 2009
    Posts
    11
    is it possible that pulseaudio is still running on top of ALSA or OSS?

  10. #10
    Just Joined!
    Join Date
    Jun 2009
    Posts
    24
    I've actually reinstalled and not touched Pulse at all; there's no sign of it on the system. The problem has become less frequent but is still occurring.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •