Find the answer to your Linux question:
Results 1 to 2 of 2
I have been working with Ubuntu 10.10 for several months now and have been generally pleased with sound and pulseaudio. I have run into a strange problem for which I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    2

    [SOLVED] Pulseaudio loses ability to record pc audio


    I have been working with Ubuntu 10.10 for several months now and have been generally pleased with sound and pulseaudio. I have run into a strange problem for which I believe I have found the cause but not the reason. I was able to record all streams then presumably, after installing install or who know - I lost the ability. Selecting the monitor function pavucontrol then recording tab, produced no active stream or sound activity.

    I used VMware to install a clean copy of Ubuntu which recorded internal sound flawlessly and discovered the problem. The default PA source was changed from an input source to an output source. See image below for the correct setup. However, any attempt to reset the default source ended up in PA not being able to connect to the server and consequently no PA. I had to go to a backup to get the sound recording working again.

    I am interested in learning what happened and how to prevent this from happening again as I experienced this same thing several months ago. When I am experiencing this problem all sound output is fine - you just cannot record any internal pc streams. Any PA experts out there? Thanks for any insight....

    Steve
    Attached Images Attached Images

  2. #2
    Just Joined!
    Join Date
    Dec 2010
    Posts
    2

    Update - Solved

    After spending hours studying the intricacies of Pulseadudio and trying to make adjustments via PA's command line interpreter, I came across a thread that offered a solution to another problem but solved mine. Deleting or renaming the user's hidden pulse directory (/home/username/.pulse) followed by restarting pulseaudio or the computer restored my ability to record audio from my computer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •