Find the answer to your Linux question:
Results 1 to 7 of 7
[ben@x1-6-00-40-2b-35-4f-37 ben]$ gmplayer MPlayer 1.0pre5-3.3.3 (C) 2000-2004 MPlayer Team CPU: Intel 2217 MHz (Family: 8, Stepping: 10) Detected cache-line size is 64 bytes CPUflags: MMX: 1 MMX2: 1 3DNow: 0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User benjamin20's Avatar
    Join Date
    Oct 2004
    Location
    jacksonville beach FL
    Posts
    317

    mplayer gui


    [ben@x1-6-00-40-2b-35-4f-37 ben]$ gmplayer
    MPlayer 1.0pre5-3.3.3 (C) 2000-2004 MPlayer Team

    CPU: Intel 2217 MHz (Family: 8, Stepping: 10)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

    Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
    Creating config file: /home/ben/.mplayer/config
    Reading config file /home/ben/.mplayer/config
    [cfg] read config file: /home/ben/.mplayer/gui.conf
    Reading config file /home/ben/.mplayer/gui.conf: No such file or directory
    vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
    Reading /home/ben/.mplayer/codecs.conf: Can't open '/home/ben/.mplayer/codecs.conf': No such file or directory
    Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
    Using built-in default codecs.conf.
    font: can't open file: /home/ben/.mplayer/font/font.desc
    font: can't open file: /usr/local/share/mplayer/font/font.desc
    Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
    Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
    Using usleep() timing
    Can't open input config file /home/ben/.mplayer/input.conf: No such file or directory
    Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
    Falling back on default (hardcoded) input config
    SKIN dir 1: '/home/ben/.mplayer/Skin'
    SKIN dir 2: '/usr/local/share/mplayer/Skin'

    ************************************************** ************************************************** *********8
    this is what i get when i run gmplayer. nothing pops up and i cant do anything. when i close the terminal window thse two messages pop up consecutavly but not at the same time


    ############
    MPlayer interrupted by signal 1 in moduale: unknown
    [ ok ]
    ############
    when i hit ok i get this
    ############
    - MPlayer crashed. This shouldn't happen.
    It can be a bug in the MPlayer code _or_ in
    your drivers _or_ in your
    gcc version. If you think it's MPlauer's fault,
    please read
    DOCS/HTML/en/bugreports.html and follow
    the instructions ther. We cant't and
    won't hwlp unless you provide infromation
    when reporting a possible bug.
    [ ok ]
    ################################################## #################################
    im using the nvidia drivers so could this be the modual its having a problem with?
    nVidia G-Force 6600GT (bfg) pci-e: amd 64 2000+ (939): 1024 corsair ram: 2X 80gb seagate harddisk SATA: plextor cd/dvd-read/write cdrom SATA

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    does regular mplayer work?

  3. #3
    Linux User benjamin20's Avatar
    Join Date
    Oct 2004
    Location
    jacksonville beach FL
    Posts
    317
    yes
    nVidia G-Force 6600GT (bfg) pci-e: amd 64 2000+ (939): 1024 corsair ram: 2X 80gb seagate harddisk SATA: plextor cd/dvd-read/write cdrom SATA

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    If you can, I strongly recomend installing MPlayer from the CVS snapshot on their website, as they almost always work. Just make sure you add the --enable-gui option when running configure.
    EDIT: I'm also using the nVidia drivers, maybe you forgot to install a skin for the GUI?
    Emotions are the key to the soul.
    Registered Linux User #375050

  6. #5
    Linux User benjamin20's Avatar
    Join Date
    Oct 2004
    Location
    jacksonville beach FL
    Posts
    317
    i put a skin in a few places where i thought it was looking for one like /usr/local/share/mplayer/Skin. then i tried /usr/local/share/mplayer/Skin/default. then i tried /usr/local/share/mplayer/Skin/default/skin. nothing worked. im trying blueheart for my skin. all i have to do is past the folder in the right directory right.
    nVidia G-Force 6600GT (bfg) pci-e: amd 64 2000+ (939): 1024 corsair ram: 2X 80gb seagate harddisk SATA: plextor cd/dvd-read/write cdrom SATA

  7. #6
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    Try adding the "skin=blueheart" line to the $HOME/.mplayer/gui.conf file.
    When you extract the skin, just extract it to /usr/local/share/mplayer/Skin , and rename the new directory "blueheart"
    It might also help to use the actual skin called "default" from MPlayer's website, at least untill the GUI actually runs so you set a different skin more easily.
    Emotions are the key to the soul.
    Registered Linux User #375050

  8. #7
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Oklahoma City, OK
    Posts
    232
    On first launch, MPlayer looks for a skin named "default". You can either change this in the ~/.mplayer/gui.conf file, as was suggested, or create a symlink from /usr/local/share/mplayer/Skin/BlueHeart to /usr/local/share/mplayer/Skin/default.
    In your OP, the error was also complaining about no fonts. You'll notice that the font tarball contains about 4 or 5 directories which contain fonts. You need to extract the contents of one of these directories to /usr/local/share/mplayer/fonts in order to get MPlayer-gui to launch.
    OH NOOOOO!!!!!! You did it the way I said?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •