Find the answer to your Linux question:
Results 1 to 5 of 5
Hello there. I've recently installed Cedega in hopes to play my favourite windows games on my newly installed Mandrakelinux 10.1. I installed Diablo II + expansion first and it worked ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2

    No sound with Starcraft and GTA3


    Hello there.
    I've recently installed Cedega in hopes to play my favourite windows games on my newly installed Mandrakelinux 10.1. I installed Diablo II + expansion first and it worked like a charm. In fact, I think it runs even smoother than it did when I had WinXP. Anyway, I decided to install Starcraft and GTA3 as well. They both installed fine, but none of them had audio! I've tried switching from OSS to ALSA and back, but still nothing! Also, while GTA3 runs okay even without sound, Starcraft lags. A LOT. What could be the problem? Why does D2 work perfectly and Starcraft doesn't?
    Could anyone help? These are my fave games. Thanks in advance!

  2. #2
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2
    Anyone? Noone?
    If it helps any, I've just discovered that cedega isn't the only one that has sound problems. Some applications like Gaim don't even produce any or do with a lag. Example: I go to sound settings, pick a sound like "Send Message" and click "Test". Nothing. Just as I rise up to leave the puter (that's approx. 15 seconds afterwards) I hear the sound I wanted to test. Also, in TuxRacer, the sound lags for 2 seconds or something (example: I hear the popping sound 2 seconds after I pick up a herring and so on...)

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4

    I know what your problem should be

    arts or esound are realtime audio servers that run in the background of KDE or Gnome so you can have groovy multiple audio outputs.

    Unfortunately they eat CPU time and they both also tend to lag a lot...

    You need to either:

    disable esd in gnome if you use it (in the start-here:/// location in nautilus, it will be in preferences/sound)...

    or...

    In the KDE control panel goto the Sound Server option (near the bottom.. I don't use KDE too much) and disable the sound server there...

    or you could run either of these in a terminal:

    ps -A |grep artsd <------- (to find if arts is running)

    if artsd is running (you see the command return a number and artsd) do this:

    killall artsd

    this should kill artsd for you and you should get a instant speed up!

    if it's esd that causing the problems (it should be auto disabled)

    ps -A |grep esd
    killall esd

    You don't really need these sound servers if you have a good soundcard (I use the SBLive! cheapo version and it works) you should find you can play multiple audio on hardware!

    Edit: I use blackbox for gaming in Linux - you get a speedup.

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Location
    Rotorua, NZ
    Posts
    21
    Does this mean that as long as you have an actual hardware sound card then you don't need the sound servers to get in-game sound?

  5. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4
    Hopefully, yes.

    As long as your soundcard can play from two or more programs at the same time you shouldn't need a soundserver, arts can be handy for certain things though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •