Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I am unable to install VLC or any other media players in my SL 6.3 distro. I am using yum utility to install the packages, but i am getting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Posts
    19

    Unable to install VLC media player or any other player in SL 6.3 distr


    Hi,

    I am unable to install VLC or any other media players in my SL 6.3 distro. I am using yum utility to install the packages, but i am getting the below error messages,

    Code:
    --> Processing Dependency: libpng15.so.15()(64bit) for package: vlc-core-2.0.3-1.fc18.x86_64
    --> Processing Dependency: libudev.so.1()(64bit) for package: vlc-core-2.0.3-1.fc18.x86_64
    ---> Package x264-libs.x86_64 0:0.124-5.20120616.fc18 will be installed
    --> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: x264-libs-0.124-5.20120616.fc18.x86_64
    ---> Package xvidcore.x86_64 0:1.3.2-3.fc17 will be installed
    --> Processing Dependency: libm.so.6(GLIBC_2.15)(64bit) for package: xvidcore-1.3.2-3.fc17.x86_64
    --> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: xvidcore-1.3.2-3.fc17.x86_64
    --> Finished Dependency Resolution
    Error: Package: x264-libs-0.124-5.20120616.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: lame-libs-3.99.5-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: vlc-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
    Error: Package: ffmpeg-libs-0.11.1-2.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libudev.so.1(LIBUDEV_183)(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.16)(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.15)(64bit)
    Error: Package: a52dec-0.7.4-16.fc17.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: vlc-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: qt4(x86-64) >= 4.8.2
               Installed: 1:qt-4.6.2-24.el6.x86_64 (base/$releasever)
                   qt4(x86-64) = 4.6.2-24.el6
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libbluray.so.1()(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
    Error: Package: libmad-0.15.1b-15.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: vlc-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: live555-0-0.37.2012.04.27.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: vlc-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libm.so.6(GLIBC_2.15)(64bit)
    Error: Package: xvidcore-1.3.2-3.fc17.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: live555-0-0.37.2012.04.27.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.15)(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libmtp.so.9()(64bit)
    Error: Package: ffmpeg-libs-0.11.1-2.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libvpx.so.1()(64bit)
    Error: Package: librtmp-2.4-0.2.20110811gitc58cfb3e.fc17.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: vlc-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libprojectM.so.2.0.1()(64bit)
    Error: Package: xvidcore-1.3.2-3.fc17.x86_64 (rpmfusion-free-rawhide)
               Requires: libm.so.6(GLIBC_2.15)(64bit)
    Error: Package: vlc-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libz.so.1(ZLIB_1.2.3.3)(64bit)
    Error: Package: ffmpeg-libs-0.11.1-2.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libcdio_paranoia.so.1(CDIO_PARANOIA_1)(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libudev.so.1()(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libmatroska.so.5()(64bit)
    Error: Package: libdvbpsi-0.2.2-2.fc17.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: ffmpeg-libs-0.11.1-2.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libcdio_cdda.so.1()(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libm.so.6(GLIBC_2.15)(64bit)
    Error: Package: ffmpeg-libs-0.11.1-2.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libopenjpeg.so.1()(64bit)
    Error: Package: ffmpeg-libs-0.11.1-2.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libz.so.1(ZLIB_1.2.0)(64bit)
    Error: Package: 1:faad2-libs-2.7-2.fc17.x86_64 (rpmfusion-free-rawhide)
               Requires: libc.so.6(GLIBC_2.14)(64bit)
    Error: Package: ffmpeg-libs-0.11.1-2.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libcelt0.so.2()(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libpng15.so.15(PNG15_0)(64bit)
    Error: Package: ffmpeg-libs-0.11.1-2.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libcdio_paranoia.so.1()(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libproxy.so.1()(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libz.so.1(ZLIB_1.2.0.2)(64bit)
    Error: Package: vlc-core-2.0.3-1.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libpng15.so.15()(64bit)
    Error: Package: ffmpeg-libs-0.11.1-2.fc18.x86_64 (rpmfusion-free-rawhide)
               Requires: libcdio_cdda.so.1(CDIO_CDDA_1)(64bit)
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    I think it is missing some rpms do i need to manually download the rpms for yum installation. Even i have tried with 'Add/Remove Software' package manager getting the same error for VLC and M Player. Please help.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    it appears as though you are using a Fedora 17 repo or something on your SL 6 box? Don't do that!

    Use the vlc package compiled for RHEL 6 provided by the ATrpms repo.

    The vlc package is listed here:

    http://packages.atrpms.net/dist/el6/vlc/

    Instructions for install the ATrpms repo are here:

    http://atrpms.net/documentation/install/

  3. #3
    Just Joined!
    Join Date
    Aug 2012
    Posts
    19
    I have downloaded the ATrpms repo and installed it. But i couldn't able to VLC still getting the below error,

    Code:
    ---> Package orc.x86_64 0:0.4.16-6.el6 will be installed
    ---> Package tslib.x86_64 0:1.0-2.el6 will be installed
    ---> Package vlc.x86_64 0:2.0.3-3.el6 will be installed
    --> Processing Dependency: libupnp.so.3()(64bit) for package: vlc-2.0.3-3.el6.x86_64
    --> Processing Dependency: libthreadutil.so.2()(64bit) for package: vlc-2.0.3-3.el6.x86_64
    --> Finished Dependency Resolution
    Error: Package: vlc-2.0.3-3.el6.x86_64 (atrpms)
               Requires: libupnp.so.3()(64bit)
               Available: libupnp-1.6.6-1.el6.rf.x86_64 (rpmforge)
                   libupnp.so.3()(64bit)
               Available: libupnp-1.6.6-3.el6.x86_64 (atrpms)
                   libupnp.so.3()(64bit)
               Installed: libupnp-1.6.13-1.el6.x86_64 (@epel)
                   Not found
    Error: Package: vlc-2.0.3-3.el6.x86_64 (atrpms)
               Requires: libthreadutil.so.2()(64bit)
               Available: libupnp-1.6.6-1.el6.rf.x86_64 (rpmforge)
                   libthreadutil.so.2()(64bit)
               Available: libupnp-1.6.6-3.el6.x86_64 (atrpms)
                   libthreadutil.so.2()(64bit)
               Installed: libupnp-1.6.13-1.el6.x86_64 (@epel)
                   Not found
    Error: Package: libavcodec53-0.10.2-54.el6.x86_64 (atrpms)
               Requires: libvpx.so.1()(64bit)
     You could try using --skip-broken to work around the problem

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    It looks like your rpmforge repo is conflicting. Try disabling it temporarily:

    Code:
    yum --disablerepo=rpmforge install vlc
    if you still get conflicts, post your list of enabled repos:

    Code:
    yum repolist

  5. #5
    Just Joined!
    Join Date
    Aug 2012
    Posts
    19
    I installed using the below link

    Code:
    scientificlinuxforum.org/index.php?showtopic=1425
    Thank you for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •