Find the answer to your Linux question:
Results 1 to 7 of 7
I installed Pulse Volume Control recently due to the near impossibility of recording sound through my current hardware and ALSA configurations. The problem is that if I run applications like: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Location
    Debian Stable AMD-64 (Gnome 3)
    Posts
    79

    Pulse "ignoring" recording applications


    I installed Pulse Volume Control recently due to the near impossibility of recording sound through my current hardware and ALSA configurations. The problem is that if I run applications like: ffmpeg or RMD, it won't register under the recording tab and this works with gnome-sound-recorder. Documentations reveal that both of these recording softwares can be used with pulse, however none of them is effective in my case.

    What should I do in order to make Pulse recognize that the applications are recording audio?

  2. #2
    Linux Newbie
    Join Date
    Jun 2012
    Posts
    100
    I see people invocing ffmpeg with '-f alsa -i pulse'. I guess you need to explicitly mention to ffmpeg that you want to use pulse. Same goes for RMD I guess.

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Location
    Debian Stable AMD-64 (Gnome 3)
    Posts
    79
    Quote Originally Posted by Rexilion View Post
    I see people invocing ffmpeg with '-f alsa -i pulse'. I guess you need to explicitly mention to ffmpeg that you want to use pulse. Same goes for RMD I guess.
    That's the problem, I include "pulse" with my command but it said this: alsa @ 0x1a9a2e0 cannot open audio device pulse. Now, in RMD, you either use pulse audio control to identify the program or just type pulse into its recording device. BOTH failed in my case, in which the control isn't able to identify RMD and RMD itself cannot find the soundcard or configure it.

  4. #4
    Linux Newbie
    Join Date
    Jun 2012
    Posts
    100
    Can you confirm that pulse is properly working? I.e. running and accepting commands? Try VLC (or Totem?) to test this. Also run the ffmpeg command again, and post all the output here. Thanks.

  5. #5
    Just Joined!
    Join Date
    Jan 2013
    Location
    Debian Stable AMD-64 (Gnome 3)
    Posts
    79
    Quote Originally Posted by Rexilion View Post
    Can you confirm that pulse is properly working? I.e. running and accepting commands? Try VLC (or Totem?) to test this. Also run the ffmpeg command again, and post all the output here. Thanks.
    PulseAudio process is running, when I run two applications that tries to play sound only one can have access to the sound card, I open up PulseAudio manager, it's connected to a client. So Pulse is indeed running. It's able to successfully identify certain applications such as Totem, System, Sound recorder as playback/recording devices.

    Code:
    ffmpeg -f alsa -ac 2 -i pulse -f x11grab -r 30 -s 1024x768 -i :0.0 -acodec pcm_s16le -vcodec libx264 -preset ultrafast -crf 0 -threads 0 output.mkv
    ffmpeg version 0.7.13, Copyright (c) 2000-2011 the FFmpeg developers
      built on Jun 13 2012 14:14:09 with gcc 4.4.5
      configuration: --enable-libdc1394 --prefix=/usr --extra-cflags='-Wall -g ' --cc='ccache cc' --enable-shared --enable-libmp3lame --enable-gpl --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libtheora --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libspeex --enable-nonfree --disable-stripping --enable-avfilter --enable-libdirac --disable-decoder=libdirac --enable-libfreetype --enable-libschroedinger --disable-encoder=libschroedinger --enable-version3 --enable-libopenjpeg --enable-libvpx --enable-librtmp --extra-libs=-lgcrypt --disable-altivec --disable-armv5te --disable-armv6 --disable-vis
      libavutil    50. 43. 0 / 50. 43. 0
      libavcodec   52.123. 0 / 52.123. 0
      libavformat  52.111. 0 / 52.111. 0
      libavdevice  52.  5. 0 / 52.  5. 0
      libavfilter   1. 80. 0 /  1. 80. 0
      libswscale    0. 14. 1 /  0. 14. 1
      libpostproc  51.  2. 0 / 51.  2. 0
    ALSA lib pcm.c:2190:(snd_pcm_open_noupdate) Unknown PCM pulse
    [alsa @ 0x9162e0] cannot open audio device pulse (No such file or directory)
    pulse: Input/output error

  6. #6
    Linux Newbie
    Join Date
    Jun 2012
    Posts
    100
    I'm out of clues here. You should investigate the ffmpeg switches and dig further in that direction. Maybe ffmpeg does not have pulseaudio support (compiled?). Maybe you need to install another package for that? (plugin?)

  7. #7
    Just Joined!
    Join Date
    Jan 2013
    Location
    Debian Stable AMD-64 (Gnome 3)
    Posts
    79
    Quote Originally Posted by Rexilion View Post
    I'm out of clues here. You should investigate the ffmpeg switches and dig further in that direction. Maybe ffmpeg does not have pulseaudio support (compiled?). Maybe you need to install another package for that? (plugin?)
    Hi,

    Yes, indeed this is a stubborn case of highly complexity but this problem also occurred when recording with RMD (recordmydesktop), since it's not in active development, there's no sure way to know if the program is causing this. But this post will remain here until somebody (preferably someone seasonable) comes and resolve this issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •