Find the answer to your Linux question:
Results 1 to 9 of 9
Seriously the documentation is **** for this. Frankly I don't know what I need to do with lirc since documentation is all over the place and out of date. I'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142

    LIRC I'm confused.


    Seriously the documentation is **** for this.

    Frankly I don't know what I need to do with lirc since documentation is all over the place and out of date.

    I'm trying to set up LIRC to ir blast Digital Set Top Boxes, but everything I read keep saying I need to have /dev/lirc0 device.

    What I'm trying to do is use HVR-1950 IR Emitter to blast a cisco DTA170HD.

    Now I have ir_rx_z8f0811_haup and ir_tx_z8f0811_haup showing up in dmesg, I've modprobe lirc_dev and ir-kbd-i2c not sure what else I need, since there is no damn list or table but hey they got a database full of remotes!

    but /dev/lirc doesn't show up, I don't know if this is necessary?

    I don't know if I need to specify that /dev/inputs/event7 is /dev/lirc0

    or if my hardware.conf is wrong or it I need to set something in /etc/sysconfig/lirc.

    Basically I got rid of hardware.conf since I created it by hand and didn't know if remote is the same as transmitter because I've seen other guides where people just filled in remote and then did irsend and were able to turn off the box and so on.

    As you can see I'm confused heavily.

    I'm using lirc 0.9 from epel running on centos 6.2.

    Can some one help me configure lirc?

  2. #2
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,084
    Maybe I'm missing something but I don't see the Cisco product in the supported hardware list: LIRC - Linux Infrared Remote Control

    In the section here LIRC - Linux Infrared Remote Control it doesn't seem obvious to me that the device would be supported.

  3. #3
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142
    It doesn't need to, it uses the same remote codes as scientific Atlanta 8300HD, and it shouldn't matter because that devices is listening for IR commands to change channel. what I need is the HVR-1950 with it's IR Emitter to tell the DTA to change channel and that's what I'm after. It should be possible. Problem is I need to know if the IR Emitter works the same using ir-kbd-i2c that it will emit light instead of just receiving it.

    That's the problem I am having because there are no hardware.conf I can look at or see what drivers I need, or whether hardware.conf is where I tell lirc to create /dev/lirc0 via "TRANSMITTER DEVICE," or if lirc0 is automatically created by the lirc and I should define "TRANSMITTER DEVICE" to point to /dev/inputs/event7,8,9 or not because it's too damn vague.

    Basically I have three HVR-1950 that need to be setup like this, and only got two DTA170HD for now as test concept.

    ------>(DTA170HD Cable Box)------>(HVR-1950 TUNER)------->(PC-USB)----->(Mythtv)

    Seriously LIRC documentation is the worst I've seen, I've never seen such outdated vague information and no example conf files either.

    Also HVR-1950 is Hauppauge TV card which uses lirc_dev lirc_i2c, but guess what "FATAL: Module lirc_i2c not found." becuase it doesn't exist anymore they change the name on it, and I don't know what it is!

  4. #4
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,084
    The documentation certainly reads like a DYI. Did you compile a kernel or just a module? Did you use the setup script?

    I'm asking since you're more likely to get the right help if you explain what you've done so far.

  5. #5
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142
    no, I used epel repo for lirc stuff, I modprobe lirc_dev and ir-kbd-i2c but I don't know if that is the right module needed.

    But somewhere between 2.6.27 and 2.6.32 lirc decided to do a clean up on lirc modules and change the names on them. Their docs don't reflect these changes, so I'm guessing here.

    I'm about this close to say "**** this" and return these DTA170HD boxes, call my cable co and tell them to shove their service up their ass for killing analog line up.

  6. #6
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142
    Ok, Here's where I'm at now:

    I downloaded lirc-0.9.0.tat.bz2

    untar it.

    ./configure --with-driver=all

    ran Make

    Compiled, then make install.

    Now modinfo lirc_i2c
    Code:
    filename:       /lib/modules/2.6.32-220.23.1.el6.x86_64/misc/lirc_i2c.ko
    license:        GPL
    author:         Gerd Knorr, Michal Kochanowicz, Christoph Bartelmus, Ulrich Mueller, Stefan Jahn, Jerome Brock
    description:    Infrared receiver driver for Hauppauge and Pixelview cards (i2c stack)
    srcversion:     9F86C1DA31548DB4D8B2BDA
    depends:        i2c-core,lirc_dev
    vermagic:       2.6.32-220.23.1.el6.x86_64 SMP mod_unload modversions
    parm:           minor:Preferred minor device number (int)
    parm:           debug:Enable debugging messages (bool)
    Then when I tried to modprobe it, I got
    Code:
    FATAL: Error inserting lirc_i2c (/lib/modules/2.6.32-220.23.1.el6.x86_64/misc/lirc_i2c.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    dmesg says:
    Code:
    lirc_dev: IR Remote Control driver registered, major 248
    lirc_i2c: disagrees about version of symbol lirc_register_driver
    lirc_i2c: Unknown symbol lirc_register_driver
    So now what?

  7. #7
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142
    I'm just going to abandon my attempt on it. There's just not enough information to make it work. On the other hand I've modinfo lirc_serial then tried to modprobe it and it seems to being working even though it error out with device being busy.

    I've ordered rs232 IR blaster from MythTV LIRC RS232 IR Blaster We'll see how that goes, since there seems to plenty of information out on the net from people especially this guide from
    MythTV with Multiple Cable Boxes Controlled by IR Blasters Kolinahr

    which is what I'm trying to do.

  8. #8
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,084
    Here's a page where they've had the same problem and solved it: [ubuntu] Upgrade 9.10 --> 10.04 lirc cant load modules

    I get the sense that lirc isn't very actively supported.

  9. #9
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142
    Yep, I get that feeling too.

    I'm just going to go with serial right now, there's a plenty of information on it and I can acquire the hardware easily.

    I appreciate the help. Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •