Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20
You might need a newer version of gcc, g++, glib, you will be able to find then at www.rpmfind.net . dylunio...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157

    You might need a newer version of gcc, g++, glib, you will be able to find then at www.rpmfind.net.

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  2. #12
    Just Joined! fireman2904's Avatar
    Join Date
    Feb 2005
    Posts
    18
    i think i have the latest versions but ..maybe not.. i am downloading a lot of rpm's and im getting almost there before i get to mplayer-gui rpm. im getting the following error when installing the mplayer-common package:

    [root@homelp mplayergui]# rpm -i mplayer-common-1.0pre5-3.i386.rpm
    error: Failed dependencies:
    mplayer = 2:1.0pre5 is needed by mplayer-common-1.0pre5-3

    i have installed april-4.4.0pre5-1.i386.rpm but obviously that is not the right one.

  3. #13
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Calcutta, India
    Posts
    220
    Install the latest 1.0pre6 .. I have already mentioned :
    do it like this :

    as root,

    # rpm -Uvh mplayer-1.0pre6-1.i386.rpm mplayer-gui-1.0pre6-1.i386.rpm
    mplayer-skin-default-1.4-1.noarch.rpm

    you will need at least these 3 packages .. install them at one go .. in a single command ... as mentioned above ...

  4. #14
    Just Joined! fireman2904's Avatar
    Join Date
    Feb 2005
    Posts
    18
    DUDE! you kick ass. i didnt know i could installed too packages at once, actually i tried the three but got the error that the first one was already installed so i try the other two, and obvioulsy i downloaded the wrong mplayer-gui file cause this new one work great without asking for dependency packages needed..awesome! i was going insane cause everytime i downloaded a new package will ask it need this or that.

    thanks much
    Your the man!

  5. #15
    Just Joined!
    Join Date
    Mar 2005
    Posts
    6

  6. #16
    Just Joined!
    Join Date
    Mar 2005
    Posts
    6

  7. #17
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Calcutta, India
    Posts
    220
    sorry for such a late response ... was out of station for sumtime !!
    To fireman2904 :
    I love to kickass !!!
    anyway, was just suggesting you to install mencoder and the codec pack as well !!
    Enjoy your MPlayer !!! If any problem .., you can always come back here, I'll try my best to solve your probs ..

  8. #18
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2

    Angry Can I get Mplayer as a tarball???

    I am having problems getting to this "greysector repository," when I try to do theit import GPG step I hang up with "warning: cannot get exclusive lock on /var/lib/rpm/Packages" and nothing more happens, if I try "yum install" at that point it hangs too.

    Is there any way to get this thing as a simple tarball that I can just build? Preferably one that will compile on FC6 - I got into this because XMMS WILL NOT compile on FC6. I really don't give a damn what is on which repository, I just want to get a music player that plays MP3s (curses on Fedora and their "no patent" nonsense!!!)

    Jim Hartley

  9. #19
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Please, don't resurrect old threads. It's almost two years old

    Check this, just copy and paste http://www.fedorafaq.org/

    It's for FC5 but it should work in any distro
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  10. #20
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2

    Thumbs down How do I compile ANYTHING for FC6?

    Sorry if you think this is an old thread, but I just got here, upgrading from an OLD RedHat 7.0 that had RPMs but NO package manager/updater or anything like that ... if there was an RPM for something it might be convenient but there was always a tarball you could compile.

    Your link for FC5 does NOT work for FC6, but I did find a way to get to "livna" and add that to the other repositories ... now "xine" works but "xmms" still doesn't. OK, if I tinker a bit I may still figure out how to get xmms to work.

    But that doesn't answer the REAL question - what if I want a program that isn't in any of these repositories? Something with such low demand that nobody will expend the effort? Something 6-8 years old that ran fine on RH7.0 and I still want to use it? I am getting the feeling that Fedora is very user-unfriendly when you want to compile some weird software from a tarball. Who is in charge of what programs I run? Is it the Fedora and repository maintainers, or is it ME?? I always thought that was the idea behind Open Source, I can choose to tinker with the source and recompile a version that suits ME. These problems playing MP3s are just a symptom of a loss of control on the user's part.

    Instead of hunting down yet one more repository looking for a version of xmms with the right plugins, I SHOULD be able to simply build from the source on the xmms page ... and it doesn't work. Since I WAS able to compile on CentOS (rebadged RHEL) I am forced to conclude that Fedora is BROKEN! Should I be looking for a way to make this work, or should I be looking for a different distro?

    Jim Hartley

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •