Find the answer to your Linux question:
Results 1 to 3 of 3
I'm trying to install Quake2 on Ubuntu 5.04 (debian based). I'm following the "Linux Quake HOWTO" pretty much line for line and everything goes smoothly until I get to running ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    7

    Installing Quake2 on Ubuntu...It won't run!


    I'm trying to install Quake2 on Ubuntu 5.04 (debian based).

    I'm following the "Linux Quake HOWTO" pretty much line for line and everything goes smoothly until I get to running the actual program using
    ./quake2

    I get the error ./quake2: No such file or directory

    but I can see it right there so I know it exists. I am in the correct directory and cannot get it to run either as root or otherwise. Also, my GL renderer is working properly.

    DETAILS OF WHAT I DID:
    1) Create the installation directory to be "/usr/local/games/quake2"
    2) Copied the entire contents of the /Install/Data folder from my Quake2 cd into the installation directory
    3) Downloaded the libc5 tar.gz linux quake file from idsoftware
    4) I untarred the above linux binaries to my "/usr/local/games/quake2" directory as root
    5) I created a "quake2.conf" file using:

    su root
    cd /usr/local/games/quake2
    pwd > /etc/quake2.conf
    chmod 644 /etc/quake2.conf

    6) at this point when I run

    cd /usr/local/games/quake2
    ./quake2

    I get the error "./quake2: No such file or directory" but doing ls I can see the quake2 linux executable is there!

    Any ideas I'd like to hear...thanks

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Location
    Randolph, NJ
    Posts
    3
    jagibbs,

    I am having the same problem only I am trying to run Quake 1. Another user pointed me to Loki's page:

    http://www.liflg.org

    Appears there are some other installers there for Quake 2.

    You could also try adding your quake2 directory to your path as such:

    PATH=$PATH:/usr/local/games/quake2

    Although this didn't work for me...logging out and back in again should remove the PATH append.

    If you come up with anything let me know, I will do likewise.

    Good Luck!

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Location
    Finland
    Posts
    2

    Loki installers

    I installed Quake 2 with Loki installer ( here ), and got it working easily though I had some problems with GL, but now it works too.

    With Quake 1 I used Loki installer too ( here ) and it worked like a charm.

    If nothing else works, try these. I can post more info how I got them working once I get back to my computer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •